aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2023-02-02 08:05:54 +0100
committerKhem Raj <raj.khem@gmail.com>2023-02-02 00:10:29 -0800
commit4ff9097409a43d8e5249abdaf935751b71aecbd0 (patch)
tree5a9442fcb2d9798f274e7d21f083eef4be1afd88 /meta-oe
parent8d298ef6d8b70f37849dc44dc98579f8ba917f0f (diff)
downloadmeta-openembedded-contrib-4ff9097409a43d8e5249abdaf935751b71aecbd0.tar.gz
rtkit: add recipe
rtkit is a runtime dependency for xdg-desktop-portal Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/rtkit/rtkit_0.13.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/rtkit/rtkit_0.13.bb b/meta-oe/recipes-support/rtkit/rtkit_0.13.bb
new file mode 100644
index 0000000000..7ae9925038
--- /dev/null
+++ b/meta-oe/recipes-support/rtkit/rtkit_0.13.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "REALTIMEKIT Realtime Policy and Watchdog Daemon"
+LICENSE = "GPL-3.0-only & BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a8e768468b658b3ed44971b53d4a6716"
+
+SRC_URI = "git://github.com/heftig/rtkit.git;protocol=https;branch=master"
+
+SRCREV = "b9169402fe5e82d20efb754509eb0b191f214599"
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig features_check useradd
+
+REQUIRED_DISTRO_FEATURES = "polkit"
+
+DEPENDS = "dbus libcap polkit xxd-native"
+
+PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
+PACKAGECONFIG[systemd] = ",,systemd"
+
+USERADD_PACKAGES = "${PN}"
+USERADD_PARAM:${PN} = "--system --no-create-home --user-group --shell /bin/nologin rtkit"
+
+FILES:${PN} += "${libdir} ${datadir}"
+