aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorShiping Ji <shji@microsoft.com>2021-10-10 21:37:33 -0700
committerKhem Raj <raj.khem@gmail.com>2021-10-14 07:16:58 -0700
commit1e12d64f70cce8bc16594a85d33dbb883f6c76ee (patch)
tree157118524d4ae56d95274735cc4a352f375dc4dd /meta-oe
parent953f6a227406fde2c2228f94c39107826af1d3b0 (diff)
downloadmeta-openembedded-contrib-1e12d64f70cce8bc16594a85d33dbb883f6c76ee.tar.gz
Add recipe for driverctl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb1
-rw-r--r--meta-oe/recipes-support/driverctl/driverctl_git.bb28
2 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
index ffb8aa665e..c35c6cb950 100644
--- a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
+++ b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
@@ -718,6 +718,7 @@ RDEPENDS:packagegroup-meta-oe-support ="\
anthy \
atop \
ace-cloud-editor \
+ driverctl \
frame \
${@bb.utils.contains("DISTRO_FEATURES", "x11", "geis", "", d)} \
grail \
diff --git a/meta-oe/recipes-support/driverctl/driverctl_git.bb b/meta-oe/recipes-support/driverctl/driverctl_git.bb
new file mode 100644
index 0000000000..7404f40c21
--- /dev/null
+++ b/meta-oe/recipes-support/driverctl/driverctl_git.bb
@@ -0,0 +1,28 @@
+SUMMARY = "driverctl is a device driver control utility for Linux"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/LGPL-2.1-only;md5=1a6d268fd218675ffea8be556788b780"
+
+REQUIRED_DISTRO_FEATURES = "systemd"
+
+DEPENDS = "systemd"
+RDEPENDS:${PN} += "bash bash-completion"
+
+SRC_URI = " git://gitlab.com/driverctl/driverctl.git"
+SRCREV = "fa9dce43d1a667d6e6e26895fbed01b3b04362c9"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig systemd features_check
+
+FILES:${PN} += "${libdir}"
+FILES:${PN} += "${libdir}/udev"
+FILES:${PN} += "${libdir}/udev/rules.d"
+FILES:${PN} += "${systemd_unitdir}"
+FILES:${PN} += "${systemd_unitdir}/system"
+FILES:${PN} += "${datadir}"
+FILES:${PN} += "${datadir}/bash-completion"
+FILES:${PN} += "${datadir}/bash-completion/completions"
+
+do_install () {
+ oe_runmake install DESTDIR=${D}
+}