aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-01-14 11:52:44 +0000
committerKhem Raj <raj.khem@gmail.com>2022-01-18 09:01:51 -0800
commite0a506536545e0a97a645093c75f9570d5aa94d4 (patch)
tree133428b8995aed7fe8beca4ed4bfe282908c5f98 /meta-oe
parent3670d61546bfce46f27ce52def370a69eb499f42 (diff)
downloadmeta-openembedded-contrib-e0a506536545e0a97a645093c75f9570d5aa94d4.tar.gz
cxxtest: move to setuptools
setup.py has always supported setuptools, so change the inherit now that distutils is deprecated. Leave S as the top of the source tree, and set SETUPUTILS_SETUP_PATH to find the setup.py. Fix the hashbang in cxxtestgen, which was still pointing at python not python3. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb13
1 files changed, 7 insertions, 6 deletions
diff --git a/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb b/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb
index b760690652..65b54ed548 100644
--- a/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb
+++ b/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb
@@ -2,21 +2,22 @@ DESCRIPTION = "CxxTest is a unit testing framework for C++ that is similar in sp
HOMEPAGE = "http://cxxtest.com/"
SECTION = "devel"
LICENSE = "LGPL-2.0"
-LIC_FILES_CHKSUM = "file://${WORKDIR}/cxxtest-${PV}/COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02"
-SRC_URI = "http://downloads.sourceforge.net/project/cxxtest/cxxtest/${PV}/cxxtest-${PV}.tar.gz"
+SRC_URI = "http://downloads.sourceforge.net/project/cxxtest/cxxtest/${PV}/${BP}.tar.gz"
SRC_URI[md5sum] = "c3cc3355e2ac64e34c215f28e44cfcec"
SRC_URI[sha256sum] = "1c154fef91c65dbf1cd4519af7ade70a61d85a923b6e0c0b007dc7f4895cf7d8"
-S = "${WORKDIR}/cxxtest-${PV}/python"
+inherit setuptools3
-inherit distutils3
+SETUPTOOLS_SETUP_PATH = "${S}/python"
do_install:append() {
install -d ${D}${includedir}
- cp -a ../cxxtest ${D}${includedir}
+ cp -a ${S}/cxxtest/ ${D}${includedir}
+ # Fix the interpretter as otherwise this points to the build host python
sed '1c\
-#!/usr/bin/env python' -i ${D}${bindir}/cxxtestgen
+#!/usr/bin/env python3' -i ${D}${bindir}/cxxtestgen
}
BBCLASSEXTEND = "native nativesdk"