aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-01-25 21:18:52 -0800
committerKhem Raj <raj.khem@gmail.com>2023-01-25 23:18:05 -0800
commitdf99d6037021dc9754b8d33d98c9c964db0f76f4 (patch)
tree3243f6e00270abd9819136d85028a230d10b0eb4 /meta-oe
parentcbd762fafc70000fb4e1c3ef9d70fdb891e5530a (diff)
downloadmeta-openembedded-contrib-df99d6037021dc9754b8d33d98c9c964db0f76f4.tar.gz
rdfind: Fix build with gcc13
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/rdfind/rdfind/0001-include-standard-headers-limits-and-cstdint.patch54
-rw-r--r--meta-oe/recipes-support/rdfind/rdfind_1.5.0.bb1
2 files changed, 55 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/rdfind/rdfind/0001-include-standard-headers-limits-and-cstdint.patch b/meta-oe/recipes-support/rdfind/rdfind/0001-include-standard-headers-limits-and-cstdint.patch
new file mode 100644
index 0000000000..bd59b74412
--- /dev/null
+++ b/meta-oe/recipes-support/rdfind/rdfind/0001-include-standard-headers-limits-and-cstdint.patch
@@ -0,0 +1,54 @@
+From 8c317f0fd5fde95a9aae2319053a196a166aec88 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 25 Jan 2023 21:12:47 -0800
+Subject: [PATCH] include standard headers <limits> and <cstdint>
+
+gcc 13 moved some includes around and as a result <cstdint> is no longer
+transitively included [1]. Explicitly include it for uint64_t.
+
+Fixes errors like below
+
+../rdfind-1.5.0/rdfind.cc:225:30: error: 'numeric_limits' is not a member of 'std'
+ 225 | o.maximumfilesize = std::numeric_limits<decltype(o.maximumfilesize)>::max();
+ | ^~~~~~~~~~~~~~
+
+...
+
+| ../rdfind-1.5.0/Fileinfo.hh:70:20: error: 'std::int64_t' has not been declared
+
+[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
+
+Upstream-Status: Submitted [https://github.com/pauldreik/rdfind/pull/129]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Fileinfo.hh | 1 +
+ rdfind.cc | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/Fileinfo.hh b/Fileinfo.hh
+index 3ffb837..23ed54e 100644
+--- a/Fileinfo.hh
++++ b/Fileinfo.hh
+@@ -8,6 +8,7 @@
+ #define Fileinfo_hh
+
+ #include <array>
++#include <cstdint>
+ #include <string>
+
+ // os specific headers
+diff --git a/rdfind.cc b/rdfind.cc
+index fbd6cb8..64dd8f6 100644
+--- a/rdfind.cc
++++ b/rdfind.cc
+@@ -9,6 +9,7 @@
+ // std
+ #include <algorithm>
+ #include <iostream>
++#include <limits>
+ #include <string>
+ #include <vector>
+
+--
+2.39.1
+
diff --git a/meta-oe/recipes-support/rdfind/rdfind_1.5.0.bb b/meta-oe/recipes-support/rdfind/rdfind_1.5.0.bb
index 0d776b4e97..8f2c5e8852 100644
--- a/meta-oe/recipes-support/rdfind/rdfind_1.5.0.bb
+++ b/meta-oe/recipes-support/rdfind/rdfind_1.5.0.bb
@@ -7,6 +7,7 @@ DEPENDS = "nettle autoconf-archive"
SRC_URI = "https://rdfind.pauldreik.se/${BP}.tar.gz \
file://0001-configure-Fix-check-for-AC_CHECK_LIB.patch \
+ file://0001-include-standard-headers-limits-and-cstdint.patch \
"
SRC_URI[sha256sum] = "4150ed1256f7b12b928c65113c485761552b9496c433778aac3f9afc3e767080"