aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorRobert Joslyn <robert.joslyn@redrectangle.org>2020-09-13 04:27:10 -0700
committerKhem Raj <raj.khem@gmail.com>2020-09-13 09:28:52 -0700
commit87229e8aaebb479c086bcdf4199bd5a3d27ca5e2 (patch)
tree654295a9ae524e7eb684615c78a04c6c6fed6550 /meta-oe
parentfb320603be7a18e540fa3df88bff39fc5f1f50b1 (diff)
downloadmeta-openembedded-contrib-87229e8aaebb479c086bcdf4199bd5a3d27ca5e2.tar.gz
consolation: Add recipe
Consolation is a daemon that provide copy-paste and scrolling support to the Linux console. It is based on the libinput library and supports all pointer devices and settings provided by this library, Similar software include gpm and jamd. Signed-off-by: Robert Joslyn <robert.joslyn@redrectangle.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb1
-rw-r--r--meta-oe/recipes-support/consolation/consolation_0.0.8.bb29
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
index 53532772a1..46cc935c66 100644
--- a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
+++ b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
@@ -686,6 +686,7 @@ RDEPENDS_packagegroup-meta-oe-support ="\
c-ares \
cmark \
${@bb.utils.contains("DISTRO_FEATURES", "polkit gobject-introspection-data", "colord", "", d)} \
+ consolation \
cpprest \
ctapi-common \
dfu-util \
diff --git a/meta-oe/recipes-support/consolation/consolation_0.0.8.bb b/meta-oe/recipes-support/consolation/consolation_0.0.8.bb
new file mode 100644
index 0000000000..90bd560c47
--- /dev/null
+++ b/meta-oe/recipes-support/consolation/consolation_0.0.8.bb
@@ -0,0 +1,29 @@
+SUMMARY = "copy-paste for the Linux console"
+DESCRIPTION = "Consolation is a daemon that provides copy-paste and scrolling \
+support to the Linux console. It is based on the libinput library and \
+supports all pointer devices and settings provided by this library. Similar \
+software include gpm and jamd."
+HOMEPAGE = "https://salsa.debian.org/consolation-team/consolation"
+SECTION = "console/utils"
+LICENSE = "GPL-2.0+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=73ca626e1d9048abfc7d599370650827"
+
+DEPENDS = " \
+ libevdev \
+ libinput \
+ udev \
+"
+
+SRC_URI = "git://salsa.debian.org/consolation-team/consolation.git"
+SRCREV = "4581eaece6e49fa2b687efbdbe23b2de452e7902"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig systemd
+
+do_install_append() {
+ install -d ${D}${systemd_system_unitdir}
+ install -m 644 ${B}/consolation.service ${D}${systemd_system_unitdir}
+}
+
+SYSTEMD_SERVICE_${PN} = "consolation.service"