aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2021-08-04 17:15:18 +0800
committerKhem Raj <raj.khem@gmail.com>2021-08-06 20:38:40 -0700
commitaf81aad996d9f0c9e5231987e76d808585c2165d (patch)
tree87ca0f3cda4dc2e3c1c6d77fa43e8a744b37d8b5 /meta-oe
parenta133111e69e78b8cff6dbc060ee6fb1da9f1f96d (diff)
downloadmeta-openembedded-contrib-af81aad996d9f0c9e5231987e76d808585c2165d.tar.gz
hdf5: improve reproducibility
Remove the build flags to improve reproducibility. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/hdf5/files/0001-cmake-remove-build-flags.patch65
-rw-r--r--meta-oe/recipes-support/hdf5/hdf5_1.8.21.bb1
2 files changed, 66 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/hdf5/files/0001-cmake-remove-build-flags.patch b/meta-oe/recipes-support/hdf5/files/0001-cmake-remove-build-flags.patch
new file mode 100644
index 0000000000..288e642fc7
--- /dev/null
+++ b/meta-oe/recipes-support/hdf5/files/0001-cmake-remove-build-flags.patch
@@ -0,0 +1,65 @@
+From 39572baac462f16b39dc385751d5c642646718d3 Mon Sep 17 00:00:00 2001
+From: Mingli Yu <mingli.yu@windriver.com>
+Date: Wed, 4 Aug 2021 17:05:10 +0800
+Subject: [PATCH] cmake: remove build flags
+
+Remove the build flags to improve reproducibility.
+
+Upstream-Status: Inappropriate[oe specific]
+
+Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
+---
+ config/cmake/libh5cc.in | 2 +-
+ config/cmake/libhdf5.settings.cmake.in | 12 ++++++------
+ 2 files changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/config/cmake/libh5cc.in b/config/cmake/libh5cc.in
+index f462d56..93c7137 100644
+--- a/config/cmake/libh5cc.in
++++ b/config/cmake/libh5cc.in
+@@ -29,4 +29,4 @@ printf 'dir is %s\n' "$dir"
+
+ export PKG_CONFIG_PATH=$dir/lib/pkgconfig
+
+-@_PKG_CONFIG_COMPILER@ `pkg-config --define-variable=prefix=$dir --cflags --libs @_PKG_CONFIG_LIBNAME@-@_PKG_CONFIG_VERSION@` $@
++`pkg-config --define-variable=prefix=$dir --cflags --libs @_PKG_CONFIG_LIBNAME@-@_PKG_CONFIG_VERSION@` $@
+diff --git a/config/cmake/libhdf5.settings.cmake.in b/config/cmake/libhdf5.settings.cmake.in
+index c337dea..0ab9066 100644
+--- a/config/cmake/libhdf5.settings.cmake.in
++++ b/config/cmake/libhdf5.settings.cmake.in
+@@ -16,8 +16,8 @@ General Information:
+ Compiling Options:
+ ------------------
+ Compilation Mode: @CMAKE_BUILD_TYPE@ @CMAKE_C_COMPILER_VERSION@
+- C Compiler: @CMAKE_C_COMPILER@
+- CFLAGS: @CMAKE_C_FLAGS@
++ C Compiler:
++ CFLAGS:
+ H5_CFLAGS: @H5_CFLAGS@
+ AM_CFLAGS: @AM_CFLAGS@
+ CPPFLAGS: @CPPFLAGS@
+@@ -29,8 +29,8 @@ Compiling Options:
+ LDFLAGS: @CMAKE_SHARED_LINKER_FLAGS@
+ AM_LDFLAGS: @AM_LDFLAGS@
+ Extra libraries: @LINK_LIBS@
+- Archiver: @CMAKE_AR@
+- Ranlib: @CMAKE_RANLIB@
++ Archiver:
++ Ranlib:
+ Debugged Packages: @DEBUG_PKG@
+ API Tracing: @HDF5_ENABLE_TRACE@
+
+@@ -46,8 +46,8 @@ Languages:
+ @BUILD_FORTRAN_CONDITIONAL_TRUE@ Static Fortran Library: YES
+
+ C++: @HDF5_BUILD_CPP_LIB@
+-@BUILD_CXX_CONDITIONAL_TRUE@ C++ Compiler: @CMAKE_CXX_COMPILER@ @CMAKE_CXX_COMPILER_VERSION@
+-@BUILD_CXX_CONDITIONAL_TRUE@ C++ Flags: @CMAKE_CXX_FLAGS@
++@BUILD_CXX_CONDITIONAL_TRUE@ C++ Compiler:
++@BUILD_CXX_CONDITIONAL_TRUE@ C++ Flags:
+ @BUILD_CXX_CONDITIONAL_TRUE@ H5 C++ Flags: @H5_CXXFLAGS@
+ @BUILD_CXX_CONDITIONAL_TRUE@ AM C++ Flags: @AM_CXXFLAGS@
+ @BUILD_CXX_CONDITIONAL_TRUE@ Shared C++ Library: @H5_ENABLE_SHARED_LIB@
+--
+2.17.1
+
diff --git a/meta-oe/recipes-support/hdf5/hdf5_1.8.21.bb b/meta-oe/recipes-support/hdf5/hdf5_1.8.21.bb
index b1de0d8b7c..7b886a4635 100644
--- a/meta-oe/recipes-support/hdf5/hdf5_1.8.21.bb
+++ b/meta-oe/recipes-support/hdf5/hdf5_1.8.21.bb
@@ -16,6 +16,7 @@ SRC_URI = " \
file://H5Tinit-32.c \
file://0001-cross-compiling-support.patch \
file://0002-Remove-suffix-shared-from-shared-library-name.patch \
+ file://0001-cmake-remove-build-flags.patch \
"
SRC_URI[md5sum] = "2d2408f2a9dfb5c7b79998002e9a90e9"
SRC_URI[sha256sum] = "e5b1b1dee44a64b795a91c3321ab7196d9e0871fe50d42969761794e3899f40d"