aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-11-15 12:18:53 -0800
committerKhem Raj <raj.khem@gmail.com>2020-11-15 12:26:38 -0800
commit44bd7e632e57c53f0e2fed212bc44b636daba61c (patch)
treed5a40ba26ebee00bdeefa302539f10d5de26d44f /meta-oe
parentfbc28b50e9f38be2565c06c00ad2b3d9a74c8985 (diff)
downloadmeta-openembedded-contrib-44bd7e632e57c53f0e2fed212bc44b636daba61c.tar.gz
capnproto: Fix build on 32bit arches with 64bit time_t defaults
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/capnproto/capnproto/0001-mutex-Fix-build-on-32-bit-architectures-using-64-bit.patch38
-rw-r--r--meta-oe/recipes-devtools/capnproto/capnproto_0.8.0.bb4
2 files changed, 41 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/capnproto/capnproto/0001-mutex-Fix-build-on-32-bit-architectures-using-64-bit.patch b/meta-oe/recipes-devtools/capnproto/capnproto/0001-mutex-Fix-build-on-32-bit-architectures-using-64-bit.patch
new file mode 100644
index 0000000000..43da4a9ef7
--- /dev/null
+++ b/meta-oe/recipes-devtools/capnproto/capnproto/0001-mutex-Fix-build-on-32-bit-architectures-using-64-bit.patch
@@ -0,0 +1,38 @@
+From e2a05a19e9dc51287e19cc9f11fd91449219e361 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 15 Nov 2020 12:10:28 -0800
+Subject: [PATCH] mutex: Fix build on 32-bit architectures using 64-bit time_t
+
+mutex code uses SYS_futex, which it expects from system C library.
+in glibc (/usr/include/bits/syscall.h defines it in terms of of NR_futex)
+rv32 is using 64bit time_t from get go unlike other 32bit architectures
+in glibc, therefore it wont have NR_futex defined but just NR_futex_time64
+this aliases it to NR_futex so that SYS_futex is then defined for rv32
+
+Upstream-Status: Submitted [https://github.com/capnproto/capnproto/pull/1103]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ c++/src/kj/mutex.c++ | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/c++/src/kj/mutex.c++ b/c++/src/kj/mutex.c++
+index c81cead7..e1594b11 100644
+--- a/c++/src/kj/mutex.c++
++++ b/c++/src/kj/mutex.c++
+@@ -39,7 +39,13 @@
+
+ #ifndef SYS_futex
+ // Missing on Android/Bionic.
++#ifdef __NR_futex
+ #define SYS_futex __NR_futex
++#elif defined(SYS_futex_time64)
++#define SYS_futex SYS_futex_time64
++#else
++#error "Need working SYS_futex"
++#endif
+ #endif
+
+ #ifndef FUTEX_WAIT_PRIVATE
+--
+2.29.2
+
diff --git a/meta-oe/recipes-devtools/capnproto/capnproto_0.8.0.bb b/meta-oe/recipes-devtools/capnproto/capnproto_0.8.0.bb
index 71f94badfa..54e9daee7b 100644
--- a/meta-oe/recipes-devtools/capnproto/capnproto_0.8.0.bb
+++ b/meta-oe/recipes-devtools/capnproto/capnproto_0.8.0.bb
@@ -5,7 +5,9 @@ SECTION = "console/tools"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://../LICENSE;md5=a05663ae6cca874123bf667a60dca8c9"
-SRC_URI = "git://github.com/sandstorm-io/capnproto.git;branch=release-${PV}"
+SRC_URI = "git://github.com/sandstorm-io/capnproto.git;branch=release-${PV} \
+ file://0001-mutex-Fix-build-on-32-bit-architectures-using-64-bit.patch;patchdir=../ \
+ "
SRCREV = "57a4ca5af5a7f55b768a9d9d6655250bffb1257f"
S = "${WORKDIR}/git/c++"