aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMaxin John <maxin.john@intel.com>2018-04-06 11:33:27 +0300
committerArmin Kuster <akuster808@gmail.com>2018-04-13 12:43:37 -0700
commitee25e2f3fdb9c4a6d14179891eb55ac8fa725da4 (patch)
tree6e8d24c65b1cda5f08365f8b04756ffc4353241b /meta-oe
parent9a0e1ce815d5d21cae49f83667aae82462d9edf4 (diff)
downloadmeta-openembedded-contrib-ee25e2f3fdb9c4a6d14179891eb55ac8fa725da4.tar.gz
ell: upgrade to version 0.4
1. Upgrade to version 0.4 and rename from _git to exact version _0.4 2. Fix build issues with musl libc Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/ell/ell/0001-ell-fix-build-with-musl-libc.patch39
-rw-r--r--meta-oe/recipes-core/ell/ell_0.4.bb (renamed from meta-oe/recipes-core/ell/ell_git.bb)6
2 files changed, 43 insertions, 2 deletions
diff --git a/meta-oe/recipes-core/ell/ell/0001-ell-fix-build-with-musl-libc.patch b/meta-oe/recipes-core/ell/ell/0001-ell-fix-build-with-musl-libc.patch
new file mode 100644
index 0000000000..a172a93ca5
--- /dev/null
+++ b/meta-oe/recipes-core/ell/ell/0001-ell-fix-build-with-musl-libc.patch
@@ -0,0 +1,39 @@
+From 4f8c68757b05d12392cd1a8aed174cb8e56f80e3 Mon Sep 17 00:00:00 2001
+From: "Maxin B. John" <maxin.john@intel.com>
+Date: Thu, 5 Apr 2018 17:19:44 +0300
+Subject: [PATCH] ell: fix build with musl libc
+
+musl libc doesn't implement TEMP_FAILURE_RETRY. Use the
+TEMP_FAILURE_RETRY from glibc to fix build.
+
+Upstream-Status: Submitted [https://lists.01.org/pipermail/ell/2018-April/001209.html]
+
+Signed-off-by: Maxin B. John <maxin.john@intel.com>
+---
+ ell/dbus.h | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/ell/dbus.h b/ell/dbus.h
+index a7c08d2..3ff5e0f 100644
+--- a/ell/dbus.h
++++ b/ell/dbus.h
+@@ -28,6 +28,16 @@
+ #include <stddef.h>
+ #include <stdarg.h>
+
++/* taken from glibc unistd.h for musl support */
++#ifndef TEMP_FAILURE_RETRY
++#define TEMP_FAILURE_RETRY(expression) \
++ (__extension__ \
++ ({ long int __result; \
++ do __result = (long int) (expression); \
++ while (__result == -1L && errno == EINTR); \
++ __result; }))
++#endif
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
+--
+2.4.0
+
diff --git a/meta-oe/recipes-core/ell/ell_git.bb b/meta-oe/recipes-core/ell/ell_0.4.bb
index 4354974bae..1524bd6b91 100644
--- a/meta-oe/recipes-core/ell/ell_git.bb
+++ b/meta-oe/recipes-core/ell/ell_0.4.bb
@@ -7,8 +7,10 @@ SECTION = "libs"
inherit autotools pkgconfig
S = "${WORKDIR}/git"
-SRCREV = "8192131685be0f27d6f51b14b78ef93fa7f3c692"
-SRC_URI = "git://git.kernel.org/pub/scm/libs/ell/ell.git"
+SRCREV = "b4aea06fabb2af1af01f861f8f394c75950b6d47"
+SRC_URI = "git://git.kernel.org/pub/scm/libs/ell/ell.git \
+ file://0001-ell-fix-build-with-musl-libc.patch \
+ "
do_configure_prepend () {
mkdir ${S}/build-aux