aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-04-08 19:37:31 -0700
committerArmin Kuster <akuster808@gmail.com>2018-04-13 12:43:46 -0700
commitc3e3cbe8fa77f70a72cd20b871f2a7303d62dbf5 (patch)
treecb98c32d5a598285766e13ef056ee29d535c5f36 /meta-oe
parent0b079f6958d52d9553c2a60e998ef4ee63f0dcdf (diff)
downloadmeta-openembedded-contrib-c3e3cbe8fa77f70a72cd20b871f2a7303d62dbf5.tar.gz
dbus-broker: include only if systemd is DISTO_FEATURE
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/dbus/dbus-broker_git.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/meta-oe/recipes-core/dbus/dbus-broker_git.bb b/meta-oe/recipes-core/dbus/dbus-broker_git.bb
index 51dfe8c0a2..b62bccf2c9 100644
--- a/meta-oe/recipes-core/dbus/dbus-broker_git.bb
+++ b/meta-oe/recipes-core/dbus/dbus-broker_git.bb
@@ -6,7 +6,7 @@ SECTION = "base"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=7b486c2338d225a1405d979ed2c15ce8"
-DEPENDS = "dbus glib-2.0 expat systemd"
+DEPENDS = "dbus glib-2.0 expat"
PV = "9+git${SRCPV}"
SRCREV = "ccd06b284892182af569e69046262331150e3536"
@@ -17,13 +17,16 @@ SRC_URI += "file://0002-Correct-including-directory-for-conf.patch"
S = "${WORKDIR}/git"
-inherit meson pkgconfig systemd
+inherit meson pkgconfig systemd distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "systemd"
SYSTEMD_SERVICE_${PN} = "${BPN}.service"
FILES_${PN} += "${systemd_system_unitdir}"
FILES_${PN} += "${systemd_user_unitdir}"
-RDEPENDS_${PN} = "dbus systemd"
+RDEPENDS_${PN} = "dbus"
BBCLASSEXTEND = "native"
+