aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMartin Hundebøll <mnhu@prevas.dk>2018-01-26 13:35:58 +0100
committerArmin Kuster <akuster808@gmail.com>2018-03-21 18:41:47 -0700
commitc09fcd618e3e6cb38748de96d8e6864086559d52 (patch)
tree9456af21f827d30d946e5132095867b9e35c926f /meta-oe
parenta69e51037ce5befcb051b3477a34ab3edf5ffdb0 (diff)
downloadmeta-openembedded-contrib-c09fcd618e3e6cb38748de96d8e6864086559d52.tar.gz
libgpiod: fix packaging of tools
The default packaging adds files from ${bindir} to the primary package, so that following packages don't see any files in ${bindir}. This causes the libgpiod-tools package to empty, as it is appended (+=) to PACKAGES. Change the assignment to PACKAGES to a prepend (=+) to populate the libgpiod-tools package with the gpio{detect,find,get,info,mon,set} executables. To avoid missing tools for existing installations of libgpiod, the libgpiod-tools package is setup as a recommendation by libgpiod when the tools package config is enabled. Signed-off-by: Martin Hundebøll <mnhu@prevas.dk> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/libgpiod/libgpiod.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod.bb b/meta-oe/recipes-support/libgpiod/libgpiod.bb
index 6aa27ad574..b2e3bae69b 100644
--- a/meta-oe/recipes-support/libgpiod/libgpiod.bb
+++ b/meta-oe/recipes-support/libgpiod/libgpiod.bb
@@ -18,6 +18,9 @@ PACKAGECONFIG ?= "tools"
PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev"
PACKAGECONFIG[tools] = "--enable-tools,--disable-tools,"
-PACKAGES += " ${PN}-tools"
+PACKAGES =+ " ${PN}-tools"
FILES_${PN}-tools = "${bindir}/*"
+
+RRECOMMENDS_TOOLS = "${@bb.utils.contains('PACKAGECONFIG', 'tools', '${PN}-tools', '',d)}"
+RRECOMMENDS_${PN} += "${RRECOMMENDS_TOOLS}"