aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorniko.mauno@vaisala.com <niko.mauno@vaisala.com>2018-04-11 12:44:48 +0300
committerArmin Kuster <akuster808@gmail.com>2018-05-01 18:11:13 -0700
commit2b974db822b586715a6f9d7592706f49c0e87e10 (patch)
tree1b51f9fb3a1337b8a137f8f1761bd1a66193aba4 /meta-oe
parentddda5e7b68a7df73e28099dafeaf77f29e0575d3 (diff)
downloadmeta-openembedded-contrib-2b974db822b586715a6f9d7592706f49c0e87e10.tar.gz
tslib: Align recipe content to better match v1.15
Respective changes to recipe: - updated AUTHOR field to match current author in tslib/AUTHORS file - updated LICENSE field to 'LGPLv2+ & GPLv2+' to reflect licenses in v1.15 (LGPLv2+ for shared library parts, GPLv2+ for command line utility parts) - updated LIC_FILES_CHECKSUM to contain COPYING files for both license families - Replaced EXTRA_OECONF with PACKAGECONFIG that is aligned to current configure defaults, with exception that "Tatung Webpad support" was disabled (as it was enabled by default for some reason despite being seemingly specific to a single manufacturer/product). - removed commented-out detect-stylus lines (a detect-stylus recipe was apparently available in OE-Classic) Signed-off-by: Niko Mauno <niko.mauno@vaisala.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-graphics/tslib/tslib_1.15.bb40
1 files changed, 33 insertions, 7 deletions
diff --git a/meta-oe/recipes-graphics/tslib/tslib_1.15.bb b/meta-oe/recipes-graphics/tslib/tslib_1.15.bb
index e87b411a85..7ae941a3cf 100644
--- a/meta-oe/recipes-graphics/tslib/tslib_1.15.bb
+++ b/meta-oe/recipes-graphics/tslib/tslib_1.15.bb
@@ -5,10 +5,13 @@ Tslib is generally used on embedded devices to provide a common user \
space interface to touchscreen functionality."
HOMEPAGE = "http://tslib.org/"
-AUTHOR = "Russell King w/ plugins by Chris Larson et. al."
+AUTHOR = "Martin Kepplinger <martink@posteo.de>"
SECTION = "base"
-LICENSE = "LGPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=fc178bcd425090939a8b634d1d6a9594"
+LICENSE = "LGPLv2+ & GPLv2+"
+LIC_FILES_CHKSUM = "\
+ file://COPYING;md5=fc178bcd425090939a8b634d1d6a9594 \
+ file://tests/COPYING;md5=a23a74b3f4caf9616230789d94217acb \
+"
SRC_URI = "https://github.com/kergoth/tslib/releases/download/${PV}/tslib-${PV}.tar.xz;downloadfilename=tslib-${PV}.tar.xz \
file://ts.conf \
@@ -21,7 +24,33 @@ UPSTREAM_CHECK_URI = "https://github.com/kergoth/tslib/releases"
inherit autotools pkgconfig
-EXTRA_OECONF = "--enable-shared --disable-h3600 --enable-input --disable-corgi --disable-collie --disable-mk712 --disable-arctic2 --disable-ucb1x00"
+PACKAGECONFIG ??= "debounce dejitter iir linear median pthres skip lowpass invert variance input touchkit waveshare"
+PACKAGECONFIG[debounce] = "--enable-debounce,--disable-debounce"
+PACKAGECONFIG[dejitter] = "--enable-dejitter,--disable-dejitter"
+PACKAGECONFIG[iir] = "--enable-iir,--disable-iir"
+PACKAGECONFIG[linear] = "--enable-linear,--disable-linear"
+PACKAGECONFIG[median] = "--enable-median,--disable-median"
+PACKAGECONFIG[pthres] = "--enable-pthres,--disable-pthres"
+PACKAGECONFIG[skip] = "--enable-skip,--disable-skip"
+PACKAGECONFIG[lowpass] = "--enable-lowpass,--disable-lowpass"
+PACKAGECONFIG[invert] = "--enable-invert,--disable-invert"
+PACKAGECONFIG[variance] = "--enable-variance,--disable-variance"
+PACKAGECONFIG[input] = "--enable-input,--disable-input"
+PACKAGECONFIG[tatung] = "--enable-tatung,--disable-tatung"
+PACKAGECONFIG[touchkit] = "--enable-touchkit,--disable-touchkit"
+PACKAGECONFIG[waveshare] = "--enable-waveshare,--disable-waveshare"
+PACKAGECONFIG[ucb1x00] = "--enable-ucb1x00,--disable-ucb1x00"
+PACKAGECONFIG[mk712] = "--enable-mk712,--disable-mk712"
+PACKAGECONFIG[h3600] = "--enable-h3600,--disable-h3600"
+PACKAGECONFIG[dmc] = "--enable-dmc,--disable-dmc"
+PACKAGECONFIG[linear-h2200] = "--enable-linear-h2200,--disable-linear-h2200"
+PACKAGECONFIG[corgi] = "--enable-corgi,--disable-corgi"
+PACKAGECONFIG[collie] = "--enable-collie,--disable-collie"
+PACKAGECONFIG[arctic2] = "--enable-arctic2,--disable-arctic2"
+PACKAGECONFIG[dmc_dus3000] = "--enable-dmc_dus3000,--disable-dmc_dus3000"
+PACKAGECONFIG[cy8mrln-palmpre] = "--enable-cy8mrln-palmpre,--disable-cy8mrln-palmpre"
+PACKAGECONFIG[galax] = "--enable-galax,--disable-galax"
+PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
do_install_prepend() {
install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf
@@ -32,9 +61,6 @@ do_install_append() {
install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
}
-# People should consider using udev's /dev/input/touchscreen0 symlink
-# instead of detect-stylus
-#RDEPENDS_tslib-conf_weird-machine = "detect-stylus"
RPROVIDES_tslib-conf = "libts-0.0-conf"
PACKAGES =+ "tslib-conf tslib-tests tslib-calibrate tslib-uinput"