aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorJens Rehsack <sno@netbsd.org>2019-09-23 19:26:50 +0200
committerKhem Raj <raj.khem@gmail.com>2019-09-23 12:17:18 -0700
commit0f13cc8e9aaae8b7fe5a592c6c47c6412633e3c7 (patch)
tree6530ece0b13bcbc0db9e276293c04ab59d6cd654 /meta-oe
parent6bcab95d51e1426cc3f5d9e6b2cd3054e07089e1 (diff)
downloadmeta-openembedded-contrib-0f13cc8e9aaae8b7fe5a592c6c47c6412633e3c7.tar.gz
libstatgrab: add recipe for libstatgrab-0.92
With the recent update at begin of summer, which includes the fix for nxp bsp issues, it's time to bring libstatgrab to more people than the few who use it in datacenter monitoring. Language bindings will follow once base library is settled. Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/libstatgrab/libstatgrab_0.92.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/libstatgrab/libstatgrab_0.92.bb b/meta-oe/recipes-extended/libstatgrab/libstatgrab_0.92.bb
new file mode 100644
index 0000000000..4ede3c8c6b
--- /dev/null
+++ b/meta-oe/recipes-extended/libstatgrab/libstatgrab_0.92.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Utilities to collect and visualise system statistics"
+HOMEPAGE = "http://www.i-scream.org/libstatgrab/"
+
+LICENSE = "GPL-2.0+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS = "ncurses"
+
+PACKAGES_prepend = "statgrab statgrab-dbg saidar saidar-dbg ${PN}-mrtg "
+
+# don't use the git tag unless docbooc2x is available to build the manpages
+SRC_URI = "https://github.com/libstatgrab/libstatgrab/releases/download/LIBSTATGRAB_0_92/libstatgrab-0.92.tar.gz \
+ "
+SRC_URI[md5sum] = "5362b2ddbec54b3901e7d70c22cda249"
+SRC_URI[sha256sum] = "5bf1906aff9ffc3eeacf32567270f4d819055d8386d98b9c8c05519012d5a196"
+
+# Perl5 is for tests only
+EXTRA_OECONF = "--without-perl5 --with-mnttab=/proc/mounts"
+
+inherit autotools pkgconfig
+
+FILES_statgrab = "${bindir}/statgrab"
+FILES_statgrab-dbg = "${bindir}/.debug/statgrab"
+FILES_saidar = "${bindir}/saidar"
+FILES_saidar-dbg = "${bindir}/.debug/saidar"
+FILES_${PN}-mrtg = "${bindir}/statgrab-make-mrtg-config ${bindir}/statgrab-make-mrtg-index"
+RDEPENDS_${PN}-mrtg_append = "perl statgrab"