aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorQi.Chen@windriver.com <Qi.Chen@windriver.com>2015-10-21 15:47:37 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-10-23 12:56:34 +0200
commitc092f7b1055c71f3e89e3c43a8ee0275de6e2c17 (patch)
tree759302c7af30e393c88466a2d3197b965e954514 /meta-oe
parent504791031307da2bd380ac5f6da02fc67ea71731 (diff)
downloadmeta-openembedded-contrib-c092f7b1055c71f3e89e3c43a8ee0275de6e2c17.tar.gz
rrdtool: fix useless-rpath QA issue
When building rrdtool, we would meet the following error. ERROR: QA Issue: rrdtool-python: work/core2-64-poky-linux/rrdtool /1.5.4-r0/packages-split/rrdtool-python/usr/lib/python2.7/site-packages /rrdtool.so contains probably-redundant RPATH /usr/lib [useless-rpaths] Fix this issue by removing 'LD_RUN_PATH=$(libdir)' when compiling rrdtool.so. As we use '--disable-rpath' in EXTRA_OECONF, we don't need to the to remove '--rpath=$(libdir)' in Makefile.am. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb b/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
index 91a30cf3df..d4f9834d0a 100644
--- a/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
+++ b/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
@@ -70,8 +70,8 @@ do_configure() {
sed -i -e '/PYTHON_INCLUDES="-I${/c \
PYTHON_INCLUDES="-I=/usr/include/python${PYTHON_BASEVERSION}"' \
${S}/m4/acinclude.m4
- #remove the hardcoded $(libdir) rpath
- sed -i -e 's|--rpath=$(libdir)||g' ${S}/bindings/Makefile.am
+ #remove the useless RPATH from the rrdtool.so
+ sed -i -e 's|LD_RUN_PATH=$(libdir)||g' ${S}/bindings/Makefile.am
autotools_do_configure