aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-09-22 16:00:41 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-12 10:24:45 +0200
commitef12dfc5055a7937c6a9dbcb605bba9627dc495a (patch)
tree64a7492fa16172c6259cb8b227351ae9de25ff3a /meta-oe
parent65e12fa49aedc9372ce436dcb299296c09eb2a90 (diff)
downloadmeta-openembedded-contrib-ef12dfc5055a7937c6a9dbcb605bba9627dc495a.tar.gz
recipes: use allarch instead of PACKAGE_ARCH = all
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/udev/udev-extra-rules.bb6
-rw-r--r--meta-oe/recipes-navigation/navit/navit-icons_svn.bb7
-rw-r--r--meta-oe/recipes-support/iso-codes/iso-codes_1.4.bb7
3 files changed, 8 insertions, 12 deletions
diff --git a/meta-oe/recipes-core/udev/udev-extra-rules.bb b/meta-oe/recipes-core/udev/udev-extra-rules.bb
index dfd40807f9..ec3f017a0b 100644
--- a/meta-oe/recipes-core/udev/udev-extra-rules.bb
+++ b/meta-oe/recipes-core/udev/udev-extra-rules.bb
@@ -2,7 +2,9 @@ DESCRIPTION = "Extra udev rules"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-PR = "r2"
+inherit allarch
+
+PR = "r3"
SRC_URI = " \
file://automount.rules \
@@ -31,5 +33,3 @@ do_install() {
FILES_${PN} = "${sysconfdir}/udev"
RDEPENDS_${PN} = "udev"
-PACKAGE_ARCH = "all"
-
diff --git a/meta-oe/recipes-navigation/navit/navit-icons_svn.bb b/meta-oe/recipes-navigation/navit/navit-icons_svn.bb
index 116ff43970..8688d0c1ea 100644
--- a/meta-oe/recipes-navigation/navit/navit-icons_svn.bb
+++ b/meta-oe/recipes-navigation/navit/navit-icons_svn.bb
@@ -5,17 +5,14 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/GPL-2;md5=751419260aa954499f7abaabaa882bbe
SECTION = "x11/applications"
DEPENDS = "glib-2.0 gtk+ imagemagick-native librsvg-native"
-#only icons present in the package
-PACKAGE_ARCH = "all"
-
PV = "0.1.0+svnr${SRCPV}"
-PR = "r2"
+PR = "r3"
EXTRA_OECONF = "--disable-binding-python --disable-gui-sdl --disable-samplemap --enable-avoid-float --enable-avoid-unaligned --enable-svg2png-scaling-flag=32 --disable-speech-speech-dispatcher"
S = "${WORKDIR}/xpm"
-inherit autotools
+inherit autotools allarch
FILES_${PN} = " /usr/share/navit/xpm/"
diff --git a/meta-oe/recipes-support/iso-codes/iso-codes_1.4.bb b/meta-oe/recipes-support/iso-codes/iso-codes_1.4.bb
index de1893dadb..c9b9113ec1 100644
--- a/meta-oe/recipes-support/iso-codes/iso-codes_1.4.bb
+++ b/meta-oe/recipes-support/iso-codes/iso-codes_1.4.bb
@@ -1,13 +1,12 @@
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://LGPL-2.1;md5=fbc093901857fcd118f065f900982c24"
-PACKAGE_ARCH = "all"
+PR = "r1"
+
SRC_URI = "ftp://pkg-isocodes.alioth.debian.org/pub/pkg-isocodes/iso-codes-${PV}.tar.bz2"
SRC_URI[md5sum] = "4073466e57df23d39721513219e4f7ae"
SRC_URI[sha256sum] = "0a7cf177c25b3f0d77c60a5f1149aab9e03ba70f69bac70138a867efe19a1d97"
-inherit autotools
+inherit autotools allarch
FILES_${PN} += "${datadir}/xml/"
-PACKAGE_ARCH = "all"
-