aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2019-08-29 23:57:28 +0800
committerKhem Raj <raj.khem@gmail.com>2019-08-29 09:07:34 -0700
commitd8685320a4dd7bb4f125494dd1fd65ba648b5c21 (patch)
treef379eb6a25a76ac47159a7c170085984bc08f6fc /meta-oe
parentdebaffd2d29665c5c0267a9cec1fc0fecaaf52f6 (diff)
downloadmeta-openembedded-contrib-d8685320a4dd7bb4f125494dd1fd65ba648b5c21.tar.gz
cryptsetup: add libdevmapper to RDEPENDS
Since commit [libdevmapper/lvm2: force recipe libdevmapper to populate sysroot only] applied, if recipe DEPENDS on libdevmapper, we have to add it to packages RDEPENDS to fix [file-rdeps] QA issue Skip [build-deps] and [file-rdeps] QA checking, add lvm2 to DEPENDS will triger circular dependencies, use recipe libdevmapper to replace, ignore the QA checking is fine. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-crypto/cryptsetup/cryptsetup_2.2.0.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-oe/recipes-crypto/cryptsetup/cryptsetup_2.2.0.bb b/meta-oe/recipes-crypto/cryptsetup/cryptsetup_2.2.0.bb
index 6ebf1e279f..194842ef80 100644
--- a/meta-oe/recipes-crypto/cryptsetup/cryptsetup_2.2.0.bb
+++ b/meta-oe/recipes-crypto/cryptsetup/cryptsetup_2.2.0.bb
@@ -16,6 +16,10 @@ DEPENDS = " \
util-linux \
"
+RDEPENDS_${PN} = " \
+ libdevmapper \
+"
+
SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/v${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}/${BP}.tar.xz"
SRC_URI[md5sum] = "f7818082056e5bc0be12e4c7fc20345a"
SRC_URI[sha256sum] = "9d8f8cac2836a1623c075b5cba96032271dc81a28b2aa27fbd8331e831416bb1"
@@ -85,4 +89,6 @@ EXTRA_OECONF += "--disable-libargon2"
FILES_${PN} += "${@bb.utils.contains('DISTRO_FEATURES','systemd','${exec_prefix}/lib/tmpfiles.d/cryptsetup.conf', '', d)}"
+INSANE_SKIP_${PN} += "build-deps file-rdeps"
+
BBCLASSEXTEND = "native nativesdk"