aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorQi.Chen@windriver.com <Qi.Chen@windriver.com>2019-08-28 15:05:43 +0800
committerKhem Raj <raj.khem@gmail.com>2019-08-29 09:06:54 -0700
commita0c7656058c3b4373fed96a3edda61610ef98b2c (patch)
tree4915f98d09253b92d2a027f48ca684660294b4a7 /meta-oe
parent0469a693926094187913317808fe841533c682bd (diff)
downloadmeta-openembedded-contrib-a0c7656058c3b4373fed96a3edda61610ef98b2c.tar.gz
libblockdev: fix PACKAGECONFIG regarding python
The python2 PACKAGECONFIG was added during an upgrade, defaulting to be disabled. The RDEPENDS part should be 'python' instead 'python2' because there's no python2 recipe. Also, we don't need to inherit some python classes. We just need to specify FILES variable. After this change, the python2 and python3 PACKAGECONFIG items could correctly work. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/libblockdev/libblockdev_2.22.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-extended/libblockdev/libblockdev_2.22.bb b/meta-oe/recipes-extended/libblockdev/libblockdev_2.22.bb
index c5fc928a7d..985bd03e46 100644
--- a/meta-oe/recipes-extended/libblockdev/libblockdev_2.22.bb
+++ b/meta-oe/recipes-extended/libblockdev/libblockdev_2.22.bb
@@ -8,7 +8,7 @@ SECTION = "devel/lib"
LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
-inherit autotools python3native gobject-introspection
+inherit autotools gobject-introspection
SRCREV = "f6e4538485d0442b3674e182c01ffe5a0f258ad4"
SRC_URI = " \
@@ -17,11 +17,11 @@ SRC_URI = " \
S = "${WORKDIR}/git"
-FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
+FILES_${PN} += "${libdir}/python2.7/dist-packages ${libdir}/python3.7/site-packages"
PACKAGECONFIG ??= "python3 lvm dm kmod parted fs escrow btrfs crypto mdraid kbd mpath nvdimm"
PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
-PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python2"
+PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python"
PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools, lvm2"
PACKAGECONFIG[lvm-dbus] = "--with-lvm_dbus, --without-lvm_dbus, multipath-tools, lvm2"
PACKAGECONFIG[dm] = "--with-dm, --without-dm, multipath-tools, lvm2"