aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-02-22 19:38:31 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-03-14 12:15:33 +0100
commit9afa64e6d2c482bfc807b4c6b6ed76ac519dc94e (patch)
tree31f69f76e3caf85eb50e461f33e23a53ad2fdb82 /meta-oe
parentc259f032feb7213420451972ea00d4a89eb03edb (diff)
downloadmeta-openembedded-contrib-9afa64e6d2c482bfc807b4c6b6ed76ac519dc94e.tar.gz
poppler: fix gobject introspection
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/poppler/poppler_0.37.0.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler_0.37.0.bb b/meta-oe/recipes-support/poppler/poppler_0.37.0.bb
index 59c477dbd4..2c6b1a9d96 100644
--- a/meta-oe/recipes-support/poppler/poppler_0.37.0.bb
+++ b/meta-oe/recipes-support/poppler/poppler_0.37.0.bb
@@ -11,7 +11,7 @@ SRC_URI[sha256sum] = "b89f9c5eae3bbb1046b0f767714afd75eca102a0406a3a30856778d42a
DEPENDS = "fontconfig zlib cairo lcms"
-inherit autotools pkgconfig gtk-doc
+inherit autotools pkgconfig gtk-doc gobject-introspection
PACKAGECONFIG ??= "jpeg openjpeg png tiff ${@bb.utils.contains('BBFILE_COLLECTIONS', 'qt5-layer', 'qt5', '', d)}"
PACKAGECONFIG[jpeg] = "--enable-libjpeg,--disable-libjpeg,jpeg"
@@ -28,6 +28,10 @@ EXTRA_OECONF = "\
--enable-zlib \
"
+do_compile_prepend() {
+ export GIR_EXTRA_LIBS_PATH="${B}/poppler/.libs"
+}
+
# Adjust library names when building for QT4e
QT4E_PATCHES = "${@bb.utils.contains('PACKAGECONFIG', 'qt4e', 'file://fix-qt4e-library-dependencies.patch', '', d)}"
SRC_URI_append = "${QT4E_PATCHES}"