aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-09-09 08:31:39 -0700
committerKhem Raj <raj.khem@gmail.com>2019-09-09 08:36:20 -0700
commit5d4b25aa9cf2c578327c59884ea618bf5e35c4b3 (patch)
treee0c7527f171c70bad5d255b240f137f81016d542 /meta-oe
parent26ff2b97006eacb6baf336273d8574da67feeb0a (diff)
downloadmeta-openembedded-contrib-5d4b25aa9cf2c578327c59884ea618bf5e35c4b3.tar.gz
openocd: disable werror when building with gcc
gcc 9.x warns more TOPDIR/build/tmp/work/mips32r2-yoe-linux/openocd/0.10+gitrAUTOINC+7ee618692f-r0/recipe-sysroot/usr/include/bits/string_fortified.h:71:10: error: '__builtin_memset' offset [509, 512] from the object at 'buff' is out of the bounds of referenced subobject 'reserved7' with type 'mg_io_uint8[186]' {aka 'unsigned char[186]'} at offset 322 [-Werror=array-bounds] | return __builtin___memset_chk (__dest, __ch, __len, __bos0 (__dest)); | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/openocd/openocd_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/openocd/openocd_git.bb b/meta-oe/recipes-devtools/openocd/openocd_git.bb
index df10177ae9..ab2fd7f721 100644
--- a/meta-oe/recipes-devtools/openocd/openocd_git.bb
+++ b/meta-oe/recipes-devtools/openocd/openocd_git.bb
@@ -27,7 +27,7 @@ inherit pkgconfig autotools-brokensep gettext
BBCLASSEXTEND += "nativesdk"
EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html"
-
+EXTRA_OECONF_append_toolchain-gcc = " --disable-werror "
do_configure() {
./bootstrap nosubmodule
install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/jimtcl/autosetup