aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorIoan-Adrian Ratiu <adrian.ratiu@ni.com>2018-07-27 14:20:33 +0300
committerKhem Raj <raj.khem@gmail.com>2018-07-27 19:26:51 -0700
commitc41ed7f332ea41984d26ad4a9ee242819c6a5a4c (patch)
tree06c74146fc693c27648122a7229f671b768ded18 /meta-oe
parentd00b7bd416eceb4d6aa70a572832a05d6f9870c0 (diff)
downloadmeta-openembedded-contrib-c41ed7f332ea41984d26ad4a9ee242819c6a5a4c.tar.gz
libblockdev: cleanup/fix PACKAGECONFIG/dependencies
It only makes sense to rdepend on lvm2 if lvm is enabled by the configuration and the nss and volume-key dependencies are only needed if --with-escrow is configured. These dependencies are quite big so it's good to have a way to disable them. Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb11
1 files changed, 3 insertions, 8 deletions
diff --git a/meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb b/meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb
index 4dbd04cd7b..a58871f0c9 100644
--- a/meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb
+++ b/meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb
@@ -12,8 +12,6 @@ inherit autotools python3native gobject-introspection
DEPENDS += " \
cryptsetup \
- nss \
- volume-key \
libbytesize \
btrfs-tools \
"
@@ -26,16 +24,12 @@ SRC_URI = " \
S = "${WORKDIR}/git"
-RDEPENDS_${PN} += " \
- lvm2 \
-"
-
FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
-PACKAGECONFIG ??= "python3 lvm dm kmod parted fs"
+PACKAGECONFIG ??= "python3 lvm dm kmod parted fs escrow"
PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python2"
-PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools"
+PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools, lvm2"
PACKAGECONFIG[dm] = "--with-dm, --without-dm"
PACKAGECONFIG[dmraid] = "--with-dmraid, --without-dmraid"
PACKAGECONFIG[kmod] = "--with-kbd, --without-kbd, kmod"
@@ -44,6 +38,7 @@ PACKAGECONFIG[fs] = "--with-fs, --without-fs, util-linux"
PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native"
PACKAGECONFIG[nvdimm] = "--with-nvdimm, --without-nvdimm"
PACKAGECONFIG[vdo] = "--with-vdo, --without-vdo"
+PACKAGECONFIG[escrow] = "--with-escrow, --without-escrow, nss volume-key"
export GIR_EXTRA_LIBS_PATH="${B}/src/utils/.libs"