aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2018-07-19 14:13:00 +0800
committerKhem Raj <raj.khem@gmail.com>2018-07-26 20:10:07 -0700
commit2f5819d9c37387764a600d9dc8d22bee8a71f710 (patch)
tree55cb9f395fc659630885d305ffa1105095424f41 /meta-oe
parentc031adb61d36ada4ac9afeadeaa64d43ffb76323 (diff)
downloadmeta-openembedded-contrib-2f5819d9c37387764a600d9dc8d22bee8a71f710.tar.gz
protobuf: upgrade 3.5.1 -> 3.6.0.1
License-Update: copyright year updated and clean some useless content Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/protobuf/protobuf/0001-protobuf-fix-configure-error.patch33
-rw-r--r--meta-oe/recipes-devtools/protobuf/protobuf_3.6.0.1.bb (renamed from meta-oe/recipes-devtools/protobuf/protobuf_3.5.1.bb)14
2 files changed, 43 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/protobuf/protobuf/0001-protobuf-fix-configure-error.patch b/meta-oe/recipes-devtools/protobuf/protobuf/0001-protobuf-fix-configure-error.patch
new file mode 100644
index 0000000000..a2f7a4b771
--- /dev/null
+++ b/meta-oe/recipes-devtools/protobuf/protobuf/0001-protobuf-fix-configure-error.patch
@@ -0,0 +1,33 @@
+From 52959e8e01e39139d18f752e97283e45b4b7a426 Mon Sep 17 00:00:00 2001
+From: Changqing Li <changqing.li@windriver.com>
+Date: Wed, 18 Jul 2018 17:52:34 +0800
+Subject: [PATCH] protobuf: fix configure error
+
+fix below error:
+gnu-configize: 'configure.ac' or 'configure.in' is required
+
+third_party/googletest is git submodule of protobuf. Above error
+caused by missing submodule googletest.
+
+Upstream-Status: Inappropriate [oe-specific]
+
+Signed-off-by: Changqing Li <changqing.li@windriver.com>
+---
+ configure.ac | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index aec10cf..7fbe57d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -214,7 +214,6 @@ AX_CXX_COMPILE_STDCXX([11], [noext], [mandatory])
+ # too.
+ export CFLAGS
+ export CXXFLAGS
+-AC_CONFIG_SUBDIRS([third_party/googletest])
+
+ AC_CONFIG_FILES([Makefile src/Makefile benchmarks/Makefile conformance/Makefile protobuf.pc protobuf-lite.pc])
+ AC_OUTPUT
+--
+2.7.4
+
diff --git a/meta-oe/recipes-devtools/protobuf/protobuf_3.5.1.bb b/meta-oe/recipes-devtools/protobuf/protobuf_3.6.0.1.bb
index 8cef391bd7..58507442a7 100644
--- a/meta-oe/recipes-devtools/protobuf/protobuf_3.5.1.bb
+++ b/meta-oe/recipes-devtools/protobuf/protobuf_3.6.0.1.bb
@@ -5,18 +5,19 @@ all of its internal RPC protocols and file formats."
HOMEPAGE = "https://github.com/google/protobuf"
SECTION = "console/tools"
LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=35953c752efc9299b184f91bef540095"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=37b5762e07f0af8c74ce80a8bda4266b"
DEPENDS = "zlib"
DEPENDS_append_class-target = " protobuf-native"
PV .= "+git${SRCPV}"
-SRCREV = "106ffc04be1abf3ff3399f54ccf149815b287dd9"
-SRC_URI = "git://github.com/google/protobuf.git;branch=3.5.x \
+SRCREV = "ce044817c7ba0aea27c3fd8e496635d94d20a755"
+
+SRC_URI = "git://github.com/google/protobuf.git;branch=3.6.x \
file://run-ptest \
+ file://0001-protobuf-fix-configure-error.patch \
"
-
S = "${WORKDIR}/git"
inherit autotools-brokensep pkgconfig ptest
@@ -82,3 +83,8 @@ RDEPENDS_${PN}-ptest = "bash python-protobuf"
MIPS_INSTRUCTION_SET = "mips"
BBCLASSEXTEND = "native nativesdk"
+
+LDFLAGS_append_arm = " -latomic"
+LDFLAGS_append_mips = " -latomic"
+LDFLAGS_append_powerpc = " -latomic"
+LDFLAGS_append_mipsel = " -latomic"