aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-09-01 15:43:29 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-05 14:34:23 +0200
commit336297c94959ca54a296f8e1de287d98562fbb1e (patch)
treec980c65724fec23edfb58545b8a06b5785f5bd9d /meta-oe
parent5602afe6e4dc631c33453a0b46ca5acb4c055afc (diff)
downloadmeta-openembedded-contrib-336297c94959ca54a296f8e1de287d98562fbb1e.tar.gz
pmtools: use update-alternatives for acpixtract
acpixtract is both provided by acpica and pmtools, so use update-alternatives to fix conflicts: | file /usr/bin/acpixtract conflicts between attempted installs of pmtools-20130209+git0+3ebe0e54c5-r0.i586 and acpica-20170303-r0.i586 Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/pmtools/pmtools_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/pmtools/pmtools_git.bb b/meta-oe/recipes-devtools/pmtools/pmtools_git.bb
index 94fc736b57..8491fc904d 100644
--- a/meta-oe/recipes-devtools/pmtools/pmtools_git.bb
+++ b/meta-oe/recipes-devtools/pmtools/pmtools_git.bb
@@ -15,6 +15,11 @@ COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
S = "${WORKDIR}/git"
+inherit update-alternatives
+
+ALTERNATIVE_PRIORITY = "90"
+ALTERNATIVE_${PN} = "acpixtract"
+
do_configure[noexec] = "1"
do_compile() {
oe_runmake