aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authoraehs29@gmail.com <aehs29@gmail.com>2019-09-08 00:13:28 -0700
committerKhem Raj <raj.khem@gmail.com>2019-09-08 16:26:17 -0700
commit9598df227def2c3933406b1f51cd6756a4ff3005 (patch)
treeaaf0f64bbaf6dd1ad1b56127855a2c678c9a76ed /meta-oe
parente23ac2e27efd16d0793f5b9aff862244850fdabd (diff)
downloadmeta-openembedded-contrib-9598df227def2c3933406b1f51cd6756a4ff3005.tar.gz
remmina: Fix spice protocol dependency and configuration
Spice is only compatible with x86 architectures, its dependency triggers a build error on other archs since the build system isnt able to find a provider for it. Fix dependencies to only include spice when an x86 architecture is being built, and configure the package accordingly. Signed-off-by: Alejandro Hernandez <aehs29@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/remmina/remmina_1.3.6.bb13
1 files changed, 9 insertions, 4 deletions
diff --git a/meta-oe/recipes-support/remmina/remmina_1.3.6.bb b/meta-oe/recipes-support/remmina/remmina_1.3.6.bb
index b95c400b28..cd6bc145c1 100644
--- a/meta-oe/recipes-support/remmina/remmina_1.3.6.bb
+++ b/meta-oe/recipes-support/remmina/remmina_1.3.6.bb
@@ -3,7 +3,10 @@ HOMEPAGE = "https://remmina.org"
SECTION = "Support"
LICENSE = "GPLv2 & openssl"
LIC_FILES_CHKSUM = "file://LICENSE;md5=dab7215512044d49037272ce1ac4ea8f file://LICENSE.OpenSSL;md5=c1eb3cee0a4dea27503c531267a69769"
-DEPENDS += "openssl freerdp gtk+3 gdk-pixbuf atk libgcrypt avahi-ui libsodium libssh vte json-glib libsoup-2.4 libvncserver spice spice-protocol libsecret"
+DEPENDS += "openssl freerdp gtk+3 gdk-pixbuf atk libgcrypt avahi-ui libsodium libssh vte json-glib libsoup-2.4 libvncserver libsecret"
+
+DEPENDS_append_x86 = " spice spice-protocol"
+DEPENDS_append_x86-64 = " spice spice-protocol"
DEPENDS_append_libc-musl = "libexecinfo"
LDFLAGS_append_libc-musl = " -lexecinfo"
@@ -17,7 +20,11 @@ S = "${WORKDIR}/Remmina-v${PV}"
inherit cmake
-EXTRA_OECMAKE += "-DWITH_APPINDICATOR=OFF -DWITH_GETTEXT=OFF -DWITH_TRANSLATIONS=OFF"
+EXTRA_OECMAKE += "-DWITH_APPINDICATOR=OFF -DWITH_GETTEXT=OFF -DWITH_TRANSLATIONS=OFF -DWITH_SPICE=OFF"
+
+EXTRA_OECMAKE_append_x86 = " -DWITH_SPICE=ON"
+EXTRA_OECMAKE_append_x86-64 = " -DWITH_SPICE=ON"
+
do_install_append(){
# We dont need the extra stuff form other desktop environments
@@ -29,5 +36,3 @@ do_install_append(){
RDEPENDS_${PN} = "bash"
FILES_${PN}_append = " ${datadir}/icons/hicolor/*"
-
-COMPATIBLE_HOST = '(x86_64|i.86).*-linux'