aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-09-11 14:22:41 -0700
committerKhem Raj <raj.khem@gmail.com>2019-09-11 14:24:30 -0700
commit054804de14224499d103fb11327ab62363c5e0ca (patch)
tree2ea3fa8eef5935e54e57577045c29e0b63cc82aa /meta-oe
parent2c97f18706be3d62133b8bb77ad24464b6d5e6a5 (diff)
downloadmeta-openembedded-contrib-054804de14224499d103fb11327ab62363c5e0ca.tar.gz
openocd: Add --disable-werror always
toolchain-gcc override is only valid when meta-clang is included in layers, but this knob is actually needed for gcc to work, so having an empty override would not add this option while the default compiler remains gcc Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/openocd/openocd_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/openocd/openocd_git.bb b/meta-oe/recipes-devtools/openocd/openocd_git.bb
index ab2fd7f721..241b4baa33 100644
--- a/meta-oe/recipes-devtools/openocd/openocd_git.bb
+++ b/meta-oe/recipes-devtools/openocd/openocd_git.bb
@@ -26,8 +26,8 @@ inherit pkgconfig autotools-brokensep gettext
BBCLASSEXTEND += "nativesdk"
-EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html"
-EXTRA_OECONF_append_toolchain-gcc = " --disable-werror "
+EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html --disable-werror"
+
do_configure() {
./bootstrap nosubmodule
install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/jimtcl/autosetup