aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2014-05-05 12:26:18 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2014-05-05 18:31:29 +0200
commit0502f9d575ddb0122bd10d325bd665a8964f5128 (patch)
treeff7de90ddc722ad00a6314b59e7f462ffa1fffb0 /meta-oe
parent557d978222dc9a904ce43131c0dfbac1411a8236 (diff)
downloadmeta-openembedded-contrib-0502f9d575ddb0122bd10d325bd665a8964f5128.tar.gz
dbench: Fix out of tree build
This fixes the Makefile so the client.txt file is copied from the original source tree. This fixes the out of tree build error. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-benchmark/dbench/files/destdir.patch4
-rw-r--r--meta-oe/recipes-benchmark/dbench/files/makefile.patch6
2 files changed, 5 insertions, 5 deletions
diff --git a/meta-oe/recipes-benchmark/dbench/files/destdir.patch b/meta-oe/recipes-benchmark/dbench/files/destdir.patch
index ca9a8ee207..4cd2a35f5e 100644
--- a/meta-oe/recipes-benchmark/dbench/files/destdir.patch
+++ b/meta-oe/recipes-benchmark/dbench/files/destdir.patch
@@ -19,8 +19,8 @@ Index: dbench-3.04/Makefile.in
- ln -sf dbench.1 $(mandir)/tbench_srv.1
+ ${INSTALLCMD} -d $(DESTDIR)$(bindir) $(DESTDIR)$(datadir) $(DESTDIR)$(mandir)
+ ${INSTALLCMD} dbench tbench tbench_srv $(DESTDIR)$(bindir)
-+ ${INSTALLCMD} client.txt $(DESTDIR)$(datadir)
-+ ${INSTALLCMD} -m644 dbench.1 $(DESTDIR)$(mandir)
++ ${INSTALLCMD} @top_srcdir@/client.txt $(DESTDIR)$(datadir)
++ ${INSTALLCMD} -m644 @top_srcdir@/dbench.1 $(DESTDIR)$(mandir)
+ ln -sf dbench.1 $(DESTDIR)$(mandir)/tbench.1
+ ln -sf dbench.1 $(DESTDIR)$(mandir)/tbench_srv.1
diff --git a/meta-oe/recipes-benchmark/dbench/files/makefile.patch b/meta-oe/recipes-benchmark/dbench/files/makefile.patch
index 09d619ad38..11fb4ffbd7 100644
--- a/meta-oe/recipes-benchmark/dbench/files/makefile.patch
+++ b/meta-oe/recipes-benchmark/dbench/files/makefile.patch
@@ -10,9 +10,9 @@ Index: dbench-4.0/Makefile.in
@@ -35,7 +35,7 @@ install: all
${INSTALLCMD} -d $(DESTDIR)$(bindir) $(DESTDIR)$(datadir) $(DESTDIR)$(mandir)
${INSTALLCMD} dbench tbench tbench_srv $(DESTDIR)$(bindir)
- ${INSTALLCMD} client.txt $(DESTDIR)$(datadir)
-- ${INSTALLCMD} -m644 dbench.1 $(DESTDIR)$(mandir)
-+ ${INSTALLCMD} -m 644 dbench.1 $(DESTDIR)$(mandir)
+ ${INSTALLCMD} @top_srcdir@/client.txt $(DESTDIR)$(datadir)
+- ${INSTALLCMD} -m644 @top_srcdir@/dbench.1 $(DESTDIR)$(mandir)
++ ${INSTALLCMD} -m 644 @top_srcdir@/dbench.1 $(DESTDIR)$(mandir)
ln -sf dbench.1 $(DESTDIR)$(mandir)/tbench.1
ln -sf dbench.1 $(DESTDIR)$(mandir)/tbench_srv.1