aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorRicardo Ribalda Delgado <ricardo.ribalda@gmail.com>2016-12-14 00:46:12 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-26 08:23:19 +0100
commit83248edc6f4845f04986f6ef83299e44a59b1e0f (patch)
tree19a5d2ecb7a148c3cd74c71ac3e19851a7e03cff /meta-oe
parent68a23a497cad73a18b091b291ca4ccb0515aa0d7 (diff)
downloadmeta-openembedded-contrib-83248edc6f4845f04986f6ef83299e44a59b1e0f.tar.gz
opencv: Metapkg should not rdepend on -staticdev
Otherwise the running dependencies will grow considerably. Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/opencv/opencv_3.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv_3.1.bb b/meta-oe/recipes-support/opencv/opencv_3.1.bb
index fa2fdb6e6c..cf41d894cf 100644
--- a/meta-oe/recipes-support/opencv/opencv_3.1.bb
+++ b/meta-oe/recipes-support/opencv/opencv_3.1.bb
@@ -104,7 +104,7 @@ python populate_packages_prepend () {
blacklist = [ metapkg ]
metapkg_rdepends = [ ]
for pkg in packages[1:]:
- if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.endswith('-dev') and not pkg.endswith('-dbg') and not pkg.endswith('-doc') and not pkg.endswith('-locale'):
+ if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.endswith('-dev') and not pkg.endswith('-dbg') and not pkg.endswith('-doc') and not pkg.endswith('-locale') and not pkg.endswith('-staticdev'):
metapkg_rdepends.append(pkg)
d.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends))