aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-12-19 20:10:33 -0800
committerArmin Kuster <akuster808@gmail.com>2020-01-19 09:01:20 -0800
commit636660b7b2431da724d391d237d3680a72470121 (patch)
treea1a9e8d9ad56feea8b74b7004ba1012f7425f77e /meta-oe
parent2ce57e0b6c51eda6c7d8ae36ebf36ff9044b03f1 (diff)
downloadmeta-openembedded-contrib-636660b7b2431da724d391d237d3680a72470121.tar.gz
websocketapp: Fix multilib build
Fixes ERROR: websocketpp-0.8.1-r0 do_package: QA Issue: websocketpp: Files/directories were installed but not shipped in any package: /usr/lib /usr/lib/cmake /usr/lib/cmake/websocketpp /usr/lib/cmake/websocketpp/websocketpp-configVersion.cmake /usr/lib/cmake/websocketpp/websocketpp-config.cmake Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit b1a85631279b8f04b38562f9cf076f4cc0561a71) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-cmake-Use-GNUInstallDirs.patch35
-rw-r--r--meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb1
2 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-cmake-Use-GNUInstallDirs.patch b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-cmake-Use-GNUInstallDirs.patch
new file mode 100644
index 0000000000..0ef2e12375
--- /dev/null
+++ b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-cmake-Use-GNUInstallDirs.patch
@@ -0,0 +1,35 @@
+From 771d79eeb0ac5079482a4b3a131bbda744793e7d Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 19 Dec 2019 20:07:11 -0800
+Subject: [PATCH] cmake: Use GNUInstallDirs
+
+Helps install cmakefiles in right libdir
+
+Upstream-Status: Submitted [https://github.com/zaphoyd/websocketpp/pull/854]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ CMakeLists.txt | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2786aba..080be3e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -39,11 +39,13 @@ endif()
+
+ set_property(GLOBAL PROPERTY USE_FOLDERS ON)
+
++include(GNUInstallDirs)
++
+ set(INSTALL_INCLUDE_DIR include CACHE PATH "Installation directory for header files")
+ if (WIN32 AND NOT CYGWIN)
+ set (DEF_INSTALL_CMAKE_DIR cmake)
+ else ()
+- set (DEF_INSTALL_CMAKE_DIR lib/cmake/websocketpp)
++ set (DEF_INSTALL_CMAKE_DIR ${CMAKE_INSTALL_LIBDIR}/cmake/websocketpp)
+ endif ()
+ set (INSTALL_CMAKE_DIR ${DEF_INSTALL_CMAKE_DIR} CACHE PATH "Installation directory for CMake files")
+
+--
+2.24.1
+
diff --git a/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb b/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb
index 551621708c..05f14d2f42 100644
--- a/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb
+++ b/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb
@@ -8,6 +8,7 @@ DEPENDS = "openssl boost zlib"
SRC_URI = "git://github.com/zaphoyd/websocketpp.git;protocol=https \
file://0001-Replace-make_shared-with-new-in-some-cases.patch \
file://0002-Fix-missed-entries-fix-testing.patch \
+ file://0001-cmake-Use-GNUInstallDirs.patch \
"
# tag 0.8.1