aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2020-02-20 18:52:34 +0100
committerArmin Kuster <akuster808@gmail.com>2020-03-15 13:30:34 -0700
commit60d819329833d5efaabf131bf4b15c2f1316b484 (patch)
tree1e5cb45273e9935518147bb59e472bf964733935 /meta-oe
parent861e85453dc8b8249c0318bc9b4f48018abe0f3e (diff)
downloadmeta-openembedded-contrib-60d819329833d5efaabf131bf4b15c2f1316b484.tar.gz
s3c24xx-gpio, s3c64xx-gpio, sjf2410-linux-native, usbpath, wmiconfig: use git fetcher instead of svn fetcher
* svn checkouts from http://svn.openmoko.org/ are now redirected to github: svn --non-interactive --trust-server-cert co --no-auth-cache --ignore-externals -r 4949 http://svn.openmoko.org/trunk/src/target/gpio@4949 gpio Redirecting to URL 'https://github.com/openmoko/openmoko-svn': A gpio/branches A gpio/branches/oe A gpio/branches/oe/pre-20070305 A gpio/branches/oe/pre-20070305/README A gpio/branches/oe/pre-20070305/classes A gpio/branches/oe/pre-20070305/classes/autotools.bbclass A gpio/branches/oe/pre-20070305/classes/base.bbclass A gpio/branches/oe/pre-20070305/classes/openmoko-base.bbclass A gpio/branches/oe/pre-20070305/classes/openmoko-panel-plugin.bbclass * unfortunately this is causing the checkout to start from trunk, not the subdirectory specified in the URL (e.g. /trunk/src/target/gpio) and then S variable points to incorrect directory as discussed here: http://lists.openembedded.org/pipermail/openembedded-devel/2020-February/205028.html * use git fetcher directly to remove the dependency on subversion-native * for simplicity use the same SRCREV and PV for all of these, there wasn't any commit in last 8 years (not anyone can expect new commits), I don't expect anyone nowadays actually using these recipes which I've imported from meta-smartphone in 2011 - that's why I will send their removal in follow-up commit. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 6902dcd2edc3a08f6929e19e9a9c18493883f9d2) [ak: fixes build issue WARNING: s3c24xx-gpio-1.0+svnr4949-r2 do_populate_lic: Could not copy license file /home/build/builds/zeus/tmp-glibc/work/core2-64-oe-linux/s3c24xx-gpio/1.0+svnr4949-r2/gpio/gpio.c to /home/build/builds/zeus/tmp-glibc/work/core2-64-oe-linux/s3c24xx-gpio/1.0+svnr4949-r2/license-destdir/s3c24xx-gpio/gpio.c: [Errno 2] No such file or directory: '/home/build/builds/zeus/tmp-glibc/work/core2-64-oe-linux/s3c24xx-gpio/1.0+svnr4949-r2/gpio/gpio.c' ERROR: s3c24xx-gpio-1.0+svnr4949-r2 do_populate_lic: QA Issue: s3c24xx-gpio: LIC_FILES_CHKSUM points to an invalid file: /home/build/builds/zeus/tmp-glibc/work/core2-64-oe-linux/s3c24xx-gpio/1.0+svnr4949-r2/gpio/gpio.c [license-checksum] ] Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/samsung-soc-utils/s3c24xx-gpio_git.bb (renamed from meta-oe/recipes-support/samsung-soc-utils/s3c24xx-gpio_svn.bb)7
-rw-r--r--meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_git.bb (renamed from meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_svn.bb)6
-rw-r--r--meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_git.bb (renamed from meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_svn.bb)11
-rw-r--r--meta-oe/recipes-support/usbpath/usbpath_git.bb (renamed from meta-oe/recipes-support/usbpath/usbpath_svn.bb)10
-rw-r--r--meta-oe/recipes-support/wmiconfig/wmiconfig_git.bb (renamed from meta-oe/recipes-support/wmiconfig/wmiconfig_svn.bb)13
5 files changed, 22 insertions, 25 deletions
diff --git a/meta-oe/recipes-support/samsung-soc-utils/s3c24xx-gpio_svn.bb b/meta-oe/recipes-support/samsung-soc-utils/s3c24xx-gpio_git.bb
index 255754d5d1..98573a062c 100644
--- a/meta-oe/recipes-support/samsung-soc-utils/s3c24xx-gpio_svn.bb
+++ b/meta-oe/recipes-support/samsung-soc-utils/s3c24xx-gpio_git.bb
@@ -3,11 +3,10 @@ SECTION = "console/utils"
AUTHOR = "Werner Almesberger <werner@openmoko.org>"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://gpio.c;endline=12;md5=cfb91c686857b2e60852b4925d90a3e1"
-SRCREV = "4949"
-PV = "1.0+svnr${SRCPV}"
-PR = "r2"
+PV = "1.0+git${SRCPV}"
-SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gpio;protocol=http"
+SRCREV = "0bde889e6fc09a330d0e0b9eb9808b20b2bf13d1"
+SRC_URI = "git://github.com/openmoko/openmoko-svn.git;protocol=https;subpath=src/target/gpio"
S = "${WORKDIR}/gpio"
CLEANBROKEN = "1"
diff --git a/meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_svn.bb b/meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_git.bb
index 976a4f15ec..99781718c8 100644
--- a/meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_svn.bb
+++ b/meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_git.bb
@@ -3,10 +3,10 @@ SECTION = "console/utils"
AUTHOR = "Werner Almesberger <werner@openmoko.org>"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://gpio-s3c6410.c;endline=12;md5=060cda1be945ad9194593f11d56d55c7"
-SRCREV = "4949"
-PV = "1.0+svnr${SRCPV}"
+PV = "1.0+git${SRCPV}"
-SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gpio;protocol=http"
+SRCREV = "0bde889e6fc09a330d0e0b9eb9808b20b2bf13d1"
+SRC_URI = "git://github.com/openmoko/openmoko-svn.git;protocol=https;subpath=src/target/gpio"
S = "${WORKDIR}/gpio"
CLEANBROKEN = "1"
diff --git a/meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_svn.bb b/meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_git.bb
index 9e609c4dd8..7d468bae18 100644
--- a/meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_svn.bb
+++ b/meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_git.bb
@@ -3,13 +3,12 @@ SECTION = "devel"
AUTHOR = "Harald Welte <laforge@openmoko.org>"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://parport.c;endline=19;md5=b5681091b0fd8c5f7068835c441bf0c8"
-SRCREV = "4268"
-PV = "0.1+svnr${SRCPV}"
-PR = "r1"
+PV = "1.0+git${SRCPV}"
-SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=sjf2410-linux;protocol=http \
- file://0001-ppt.c-Do-not-include-sys-io.h.patch \
- "
+SRCREV = "0bde889e6fc09a330d0e0b9eb9808b20b2bf13d1"
+SRC_URI = "git://github.com/openmoko/openmoko-svn.git;protocol=https;subpath=src/host/sjf2410-linux \
+ file://0001-ppt.c-Do-not-include-sys-io.h.patch \
+"
S = "${WORKDIR}/sjf2410-linux"
inherit native deploy
diff --git a/meta-oe/recipes-support/usbpath/usbpath_svn.bb b/meta-oe/recipes-support/usbpath/usbpath_git.bb
index 6c9cd049fe..a3c75901fb 100644
--- a/meta-oe/recipes-support/usbpath/usbpath_svn.bb
+++ b/meta-oe/recipes-support/usbpath/usbpath_git.bb
@@ -8,12 +8,12 @@ DEPENDS_class-native = "virtual/libusb0-native"
BBCLASSEXTEND = "native"
-SRCREV = "3172"
-PV = "0.0+svnr${SRCPV}"
-
-SRC_URI = "svn://svn.openmoko.org/trunk/src/host;module=usbpath;protocol=http \
- file://configure.patch"
+PV = "1.0+git${SRCPV}"
+SRCREV = "0bde889e6fc09a330d0e0b9eb9808b20b2bf13d1"
+SRC_URI = "git://github.com/openmoko/openmoko-svn.git;protocol=https;subpath=src/host/usbpath \
+ file://configure.patch \
+"
S = "${WORKDIR}/usbpath"
inherit autotools pkgconfig
diff --git a/meta-oe/recipes-support/wmiconfig/wmiconfig_svn.bb b/meta-oe/recipes-support/wmiconfig/wmiconfig_git.bb
index c66572b1c1..23273caf8e 100644
--- a/meta-oe/recipes-support/wmiconfig/wmiconfig_svn.bb
+++ b/meta-oe/recipes-support/wmiconfig/wmiconfig_git.bb
@@ -2,14 +2,13 @@ SUMMARY = "Atheros 6K Wifi configuration utility"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://wmiconfig.c;endline=19;md5=4394a56bca1c5b2446c9f8e406c82911"
SECTION = "console/network"
-SRCREV = "5394"
-PV = "0.0.0+svnr${SRCPV}"
-PR = "r2"
+PV = "1.0+git${SRCPV}"
-SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=AR6kSDK.build_sw.18;protocol=http \
- file://0001-makefile-Pass-CFLAGS-to-compile.patch \
- file://0002-fix-err-API-to-have-format-string.patch \
- "
+SRCREV = "0bde889e6fc09a330d0e0b9eb9808b20b2bf13d1"
+SRC_URI = "git://github.com/openmoko/openmoko-svn.git;protocol=https;subpath=src/target/AR6kSDK.build_sw.18 \
+ file://0001-makefile-Pass-CFLAGS-to-compile.patch \
+ file://0002-fix-err-API-to-have-format-string.patch \
+"
S = "${WORKDIR}/AR6kSDK.build_sw.18/host/tools/wmiconfig"
CLEANBROKEN = "1"