aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2013-10-25 06:37:40 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-10-31 10:27:15 +0100
commit274147fc56e3f8900547841758930b6aff282069 (patch)
tree7fc36c366186975e8193844fd4f9944c477317af /meta-oe
parent615aeb15051b55e7975c7d3b28c967cd01f4dd26 (diff)
downloadmeta-openembedded-contrib-274147fc56e3f8900547841758930b6aff282069.tar.gz
mariadb-native: depends on zlib-native
Mariadb will provide zlib.* if it can't find zlib binaries and headers from sysroots path. We have set it to use external zlib.* firstly with these definitions/configs in inc file: + DEPENDS = "ncurses zlib" + --with-zlib-dir=${STAGING_EXECPREFIXDIR} But native bb file overrides the dependencies with: + DEPENDS = "ncurses-native" If mariadb-naitve was built before zlib-native, its own zlib will be built and provide zlib.la which will brake other packages link to real zlib with errors like: * .../usr/lib/libz.a(gzclose.o): relocation R_X86_64_32 against \ `a local symbol' can not be used when making a shared object; \ recompile with -fPIC * .../usr/lib/libz.a: could not read symbols: Bad value By removing the DEPENDS = "ncurses-native" from the native bb file, mariadb-native will still have the DEPENDS (ncurses zlib) from the inc file, and since the recipe is mariadb-native, this is equivalent to DEPENDS = "ncurses-native zlib-native" due to the map_dependencies() inner fuction for native_virtclass_handler() in "oe-core/meta/classes/ native.bbclass". Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/mysql/mariadb-native_5.1.67.bb1
1 files changed, 0 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/mysql/mariadb-native_5.1.67.bb b/meta-oe/recipes-support/mysql/mariadb-native_5.1.67.bb
index 01eb9649ec..a55c2ab6ae 100644
--- a/meta-oe/recipes-support/mysql/mariadb-native_5.1.67.bb
+++ b/meta-oe/recipes-support/mysql/mariadb-native_5.1.67.bb
@@ -5,7 +5,6 @@ PROVIDES += "mysql5-native"
RDEPENDS_${PN} = ""
PACKAGES = ""
-DEPENDS = "ncurses-native"
EXTRA_OEMAKE = ""
EXTRA_OECONF = " --with-embedded-server "