aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorStefan Müller-Klieser <s.mueller-klieser@phytec.de>2017-12-01 11:48:41 +0100
committerArmin Kuster <akuster808@gmail.com>2018-02-01 07:32:03 -0800
commitc993fd103de36ebfb4ad4aa9f73847a3076a3d5b (patch)
tree3652b1803638127cb8f09367b90525fa697d2e8a /meta-oe
parent1caf21276cc6b0ab96016741eadf898b94321ce0 (diff)
downloadmeta-openembedded-contrib-c993fd103de36ebfb4ad4aa9f73847a3076a3d5b.tar.gz
dfu-utils-native: fix do_deploy sstate handling
We need to install to the sstate input dir and not the output dir, so sstate handling will work correctly. Signed-off-by: Stefan Müller-Klieser <s.mueller-klieser@phytec.de> Signed-off-by: Armin Kuster <akuster808@gmail.com> (cherry picked from commit 1ef92d2423d6d6546e4f0585478540212b26f3a0) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb b/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb
index 7a7a662ab3..aeca23bf2d 100644
--- a/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb
+++ b/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb
@@ -8,9 +8,8 @@ SRC_URI += "file://0001-Revert-Makefile.am-Drop-static-dfu-util.patch"
do_deploy[sstate-outputdirs] = "${DEPLOY_DIR_TOOLS}"
do_deploy() {
- install -d ${DEPLOY_DIR_TOOLS}
- install -m 0755 src/dfu-util_static ${DEPLOY_DIR_TOOLS}/dfu-util-${PV}
- rm -f ${DEPLOY_DIR_TOOLS}/dfu-util
- ln -sf ./dfu-util-${PV} ${DEPLOY_DIR_TOOLS}/dfu-util
+ install -m 0755 src/dfu-util_static ${DEPLOYDIR}/dfu-util-${PV}
+ rm -f ${DEPLOYDIR}/dfu-util
+ ln -sf ./dfu-util-${PV} ${DEPLOYDIR}/dfu-util
}
addtask deploy before do_package after do_install