aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorbaali <shantanu@senic.com>2017-10-05 15:17:07 +0530
committerMartin Jansa <Martin.Jansa@gmail.com>2017-10-15 17:29:30 +0000
commit8efcaeeb1abc89d53a0ad659a37b12ae1c24842b (patch)
tree3a00f2c9e7bbf9a9d07094f45d006f2dfd5ec3a5 /meta-oe
parent36f873f8d59bd8b2afa962fce51b546f281c866f (diff)
downloadmeta-openembedded-contrib-8efcaeeb1abc89d53a0ad659a37b12ae1c24842b.tar.gz
nghttp2: add recipe for Nghttp2: HTTP/2 C Library.
It is also needed for Curl to support HTTP2 protocol. Signed-off-by: baali <shantanu@senic.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/nghttp2/nghttp2_1.26.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/nghttp2/nghttp2_1.26.0.bb b/meta-oe/recipes-support/nghttp2/nghttp2_1.26.0.bb
new file mode 100644
index 0000000000..3e6b10a436
--- /dev/null
+++ b/meta-oe/recipes-support/nghttp2/nghttp2_1.26.0.bb
@@ -0,0 +1,16 @@
+SUMMARY = "HTTP/2 C Library and tools"
+HOMEPAGE = "https://nghttp2.org/"
+SECTION = "libs"
+
+DEPENDS = "pkgconfig cunit zlib openssl libxml2 jansson c-ares"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = "https://github.com/nghttp2/nghttp2/releases/download/v${PV}/nghttp2-${PV}.tar.bz2"
+SRC_URI[md5sum] = "926f07ad3b50f38f7d8935ced04716cf"
+SRC_URI[sha256sum] = "0df4229f4123b5aa96e834ebcfdffe954e93d986f0252fd10123d50c6f010983"
+
+inherit cmake pythonnative python-dir
+
+EXTRA_OECMAKE = ""