aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-11-26 23:59:39 -0800
committerKhem Raj <raj.khem@gmail.com>2019-11-27 20:07:16 -0800
commit84f890bc14d40a1f0b1ac347fc4c4c3fdec7e2c5 (patch)
treec7241cd485358b984921f9b1a68804a1a45869c6 /meta-oe
parent324dec2a5521faa04fc120242f95a48d3e5fc1be (diff)
downloadmeta-openembedded-contrib-84f890bc14d40a1f0b1ac347fc4c4c3fdec7e2c5.tar.gz
pidgin: Use python3 during build
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/pidgin/pidgin/use_py3.patch20
-rw-r--r--meta-oe/recipes-support/pidgin/pidgin_2.13.0.bb1
2 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/pidgin/pidgin/use_py3.patch b/meta-oe/recipes-support/pidgin/pidgin/use_py3.patch
new file mode 100644
index 0000000000..c7b4163cb5
--- /dev/null
+++ b/meta-oe/recipes-support/pidgin/pidgin/use_py3.patch
@@ -0,0 +1,20 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1488,7 +1488,7 @@ AC_ARG_WITH([python],
+
+ if test "x$enable_dbus" = "xyes" || test "x$enable_consoleui" = "xyes" ; then
+ if test -z "$PYTHON" -o "x$PYTHON" = "xyes"; then
+- AC_PATH_PROG([PYTHON], [python], [no])
++ AC_PATH_PROG([PYTHON], [python3], [no])
+ fi
+
+ if test x"$PYTHON" = x"no" ; then
+@@ -1568,7 +1568,7 @@ dnl Check for Python headers (currently
+ dnl (Thanks to XChat)
+ if test "x$enable_consoleui" = "xyes" -a ! -z "$PYTHON" -a x"$PYTHON" != x"no" ; then
+ AC_MSG_CHECKING(for Python compile flags)
+- PKG_CHECK_MODULES(PY, python, [
++ PKG_CHECK_MODULES(PY, python3, [
+ AC_SUBST(PY_CFLAGS)
+ AC_SUBST(PY_LIBS)
+ ], [
diff --git a/meta-oe/recipes-support/pidgin/pidgin_2.13.0.bb b/meta-oe/recipes-support/pidgin/pidgin_2.13.0.bb
index b4944258fa..fdc79e81b2 100644
--- a/meta-oe/recipes-support/pidgin/pidgin_2.13.0.bb
+++ b/meta-oe/recipes-support/pidgin/pidgin_2.13.0.bb
@@ -11,6 +11,7 @@ SRC_URI = "\
file://sanitize-configure.ac.patch \
file://purple-OE-branding-25.patch \
file://pidgin-cross-python-265.patch \
+ file://use_py3.patch \
"
SRC_URI[md5sum] = "423403494fe1951e47cc75231f743bb0"