aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorJens Rehsack <rehsack@gmail.com>2015-10-27 21:22:38 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-02 15:01:10 +0100
commitc63423e305c0c68e2a9aa1ae2e7509352a85c871 (patch)
treef6a400f6e2ee2aeebb572809cc28a4ce40dafed8 /meta-oe
parent7e31db5a66573ed0670414330344b38c90d8bad4 (diff)
downloadmeta-openembedded-contrib-c63423e305c0c68e2a9aa1ae2e7509352a85c871.tar.gz
rrdtool: fix compile error
Since cpan.bbclass has evolved, the old wrapper simulation needs some adoption. Use as much as possible from cpan.bbclass instead of copying code from there. Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb14
1 files changed, 3 insertions, 11 deletions
diff --git a/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb b/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
index 2c81d56908..666ace92fc 100644
--- a/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
+++ b/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
@@ -15,7 +15,7 @@ SRC_URI = "\
S = "${WORKDIR}/git"
-inherit autotools-brokensep gettext pythonnative perlnative python-dir cpan-base systemd
+inherit cpan autotools-brokensep gettext pythonnative python-dir systemd
BBCLASSEXTEND = "native"
@@ -50,21 +50,13 @@ EXTRA_OECONF = " \
--disable-rpath \
"
-# don't use perl.real, this results in break issues with prebuilts since perl.real doesn't
-# know where the PERL5LIB is...
-# use wrapper perl instead
-EXTRA_OEMAKE = "PERL=${STAGING_BINDIR_NATIVE}/perl-native/perl FULLPERL=${STAGING_BINDIR_NATIVE}/perl-native/perl"
-
export BUILD_SYS
export HOST_SYS
export STAGING_LIBDIR
export STAGING_INCDIR
-# Env var which tells perl if it should use host (no) or target (yes) settings
-export PERLCONFIGTARGET = "${@is_target(d)}"
-export PERL_INC = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/${@get_perl_version(d)}/CORE"
-export PERL_LIB = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/${@get_perl_version(d)}"
-export PERL_ARCHLIB = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/${@get_perl_version(d)}"
+# emulate cpan_do_configure
+EXTRA_OEMAKE = ' PERL5LIB="${PERL_ARCHLIB}" '
do_configure() {
#fix the pkglib problem with newer automake