aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorZhixiong Chi <Zhixiong.Chi@windriver.com>2016-09-26 13:31:19 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-10-03 19:19:54 +0200
commitaad32cfc8c184ff78e484957e751dc65982575a2 (patch)
treefe2dfdd9fe29f629fcea70c1d5811df4d76f1b4c /meta-oe
parent934104ca944069817da51f70c764dae6cc66c87b (diff)
downloadmeta-openembedded-contrib-aad32cfc8c184ff78e484957e751dc65982575a2.tar.gz
mariadb: add libdbi-perl to RDEPENDS
The commands(mysql_convert_table_format and mysql_setpermission) need the supported API provided by the libdbi-perl package. So add the libdbi-perl to the variable RDEPENDS of mariabdb-server. Move libdbi-perl from meta-perl to meta-oe Signed-off-by: Zhixiong Chi <Zhixiong.Chi@windriver.com> Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/perl/libdbi-perl_1.636.bb26
-rw-r--r--meta-oe/recipes-support/mysql/mariadb.inc2
2 files changed, 27 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/perl/libdbi-perl_1.636.bb b/meta-oe/recipes-devtools/perl/libdbi-perl_1.636.bb
new file mode 100644
index 0000000000..085b904938
--- /dev/null
+++ b/meta-oe/recipes-devtools/perl/libdbi-perl_1.636.bb
@@ -0,0 +1,26 @@
+SUMMARY = "The Perl Database Interface"
+DESCRIPTION = "DBI is a database access Application Programming Interface \
+(API) for the Perl Language. The DBI API Specification defines a set \
+of functions, variables and conventions that provide a consistent \
+database interface independent of the actual database being used. \
+"
+HOMEPAGE = "http://search.cpan.org/dist/DBI/"
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+RDEPENDS_${PN} = " perl-module-carp \
+ perl-module-exporter \
+ perl-module-exporter-heavy \
+ perl-module-dynaloader \
+"
+
+LIC_FILES_CHKSUM = "file://DBI.pm;beginline=8147;endline=8151;md5=2e5f6cf47e5ad7b77dcb6172edc29292"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TI/TIMB/DBI-${PV}.tar.gz"
+SRC_URI[md5sum] = "60f291e5f015550dde71d1858dfe93ba"
+SRC_URI[sha256sum] = "8f7ddce97c04b4b7a000e65e5d05f679c964d62c8b02c94c1a7d815bb2dd676c"
+
+S = "${WORKDIR}/DBI-${PV}"
+
+inherit cpan
+
+BBCLASSEXTEND = "native"
diff --git a/meta-oe/recipes-support/mysql/mariadb.inc b/meta-oe/recipes-support/mysql/mariadb.inc
index 73905b6c06..c2d2ecf7a0 100644
--- a/meta-oe/recipes-support/mysql/mariadb.inc
+++ b/meta-oe/recipes-support/mysql/mariadb.inc
@@ -169,7 +169,7 @@ RDEPENDS_${PN}-client = "perl perl-module-getopt-long perl-module-file-temp \
RDEPENDS_${PN}-server = "perl perl-module-getopt-long perl-module-data-dumper \
perl-module-file-basename perl-module-file-path perl-module-sys-hostname \
perl-module-file-copy perl-module-file-temp perl-module-posix \
- ${PN}-client"
+ ${PN}-client libdbi-perl"
RDEPENDS_${PN}-leftovers = "perl perl-module-cwd perl-module-benchmark perl-module-getopt-long \
perl-module-posix perl-module-data-dumper perl-module-sigtrap perl-module-threads \
perl-module-threads-shared perl-module-io-socket perl-module-sys-hostname perl-module-file-copy \