aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorJonathan Liu <net147@gmail.com>2016-09-23 12:39:24 +1000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-10-03 19:18:51 +0200
commit67d6ed40bfeb219490e509f33c27ebd2a1149d30 (patch)
tree20b9532b9e5871549db4adea95e316552ea58e59 /meta-oe
parent93d85f6999d1d4eb8c5183c0ecb03c94253c8f71 (diff)
downloadmeta-openembedded-contrib-67d6ed40bfeb219490e509f33c27ebd2a1149d30.tar.gz
p7zip: do not hardcode path in native wrapper script
Signed-off-by: Jonathan Liu <net147@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/p7zip/p7zip_16.02.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb b/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb
index 9f87e9fa98..fdd51db218 100644
--- a/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb
+++ b/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb
@@ -29,8 +29,10 @@ do_install_class-native() {
# Create a shell script wrapper to execute next to 7z.so
mv ${D}${bindir}/7z ${D}${bindir}/7z.bin
- echo "#! /bin/sh" > ${D}${bindir}/7z
- echo "exec ${D}${bindir}/7z.bin \"\$@\"" >> ${D}${bindir}/7z
+ cat > ${D}${bindir}/7z << 'EOF'
+#!/bin/sh
+exec "$(dirname "$0")"/7z.bin "$@"
+EOF
chmod 0755 ${D}${bindir}/7z
}