aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-18 10:34:32 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-19 20:41:25 +0200
commit634e471d47824688ee9b958977137aca0e1528eb (patch)
treea5b4cda77b1f532302a0a25233ea86ad13dece18 /meta-oe
parent517421d503aa060324868d5fd59d110094666967 (diff)
downloadmeta-openembedded-contrib-634e471d47824688ee9b958977137aca0e1528eb.tar.gz
cppunit: add 1.21.1
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/cppunit/cppunit_1.12.1.bb25
1 files changed, 11 insertions, 14 deletions
diff --git a/meta-oe/recipes-devtools/cppunit/cppunit_1.12.1.bb b/meta-oe/recipes-devtools/cppunit/cppunit_1.12.1.bb
index 738b5df636..6487a3a074 100644
--- a/meta-oe/recipes-devtools/cppunit/cppunit_1.12.1.bb
+++ b/meta-oe/recipes-devtools/cppunit/cppunit_1.12.1.bb
@@ -1,19 +1,16 @@
-# cppunit OE build file
-# Copyright (C) 2005, Koninklijke Philips Electronics NV. All Rights Reserved
-# Released under the MIT license (see packages/COPYING)
-
-DESCRIPTION = "Unit Testing Library for C++"
-HOMEPAGE = "http://cppunit.sourceforge.net/"
-LICENSE = "LGPL"
-SECTION = "devel"
-PR = "r1"
+DESCRIPTION = "CppUnit is a C++ unit testing framework"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
SRC_URI = "${SOURCEFORGE_MIRROR}/cppunit/cppunit-${PV}.tar.gz"
+SRC_URI[md5sum] = "bd30e9cf5523cdfc019b94f5e1d7fd19"
+SRC_URI[sha256sum] = "ac28a04c8e6c9217d910b0ae7122832d28d9917fa668bcc9e0b8b09acb4ea44a"
inherit autotools binconfig
-CXXFLAGS_powerpc += "-lstdc++"
-
-
-SRC_URI[md5sum] = "bd30e9cf5523cdfc019b94f5e1d7fd19"
-SRC_URI[sha256sum] = "ac28a04c8e6c9217d910b0ae7122832d28d9917fa668bcc9e0b8b09acb4ea44a"
+# Fix a linker ordering problem, we want -ldl *after* -lstdc++
+do_configure_append() {
+ for i in $(find ${S} -name "Makefile") ; do
+ sed -i -e 's:-lm:-lm -ldl:g' $i
+ done
+}