aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2016-09-26 15:47:48 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-10-03 19:19:54 +0200
commit510bcc875c689f386595898073de2f278f8b0fdc (patch)
treed47b7d645e817322d0f7af5b189508cd281f368f /meta-oe
parent6ba3b309d7e3c2db0421ddae0f9204961b5cebdb (diff)
downloadmeta-openembedded-contrib-510bcc875c689f386595898073de2f278f8b0fdc.tar.gz
gperftools: fix to work on aarch64
Add '--disable-libunwind' to make it work on aarch64. This would avoid system hanging when using libtcmalloc.so. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/gperftools/gperftools_2.5.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/gperftools/gperftools_2.5.bb b/meta-oe/recipes-support/gperftools/gperftools_2.5.bb
index 1572d4c4f3..2e4479c9d7 100644
--- a/meta-oe/recipes-support/gperftools/gperftools_2.5.bb
+++ b/meta-oe/recipes-support/gperftools/gperftools_2.5.bb
@@ -14,5 +14,6 @@ inherit autotools
# On mips, we have the following error.
# do_page_fault(): sending SIGSEGV to ls for invalid read access from 00000008
# Segmentation fault (core dumped)
-# On aarch64, system hangs when using libtcmalloc.so.
-COMPATIBLE_HOST = "(i.86|x86_64|powerpc|powerpc64|arm).*-linux*"
+COMPATIBLE_HOST = "(i.86|x86_64|powerpc|powerpc64|arm|aarch64).*-linux*"
+# On aarch64, add this option to avoid system hanging when using libtcmalloc.so.
+EXTRA_OECONF_aarch64 += "--disable-libunwind"