aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorEddie James <eajames@linux.ibm.com>2018-10-09 18:17:00 +0000
committerKhem Raj <raj.khem@gmail.com>2018-12-03 08:56:52 -0800
commit5add8e838f321eb4bb75cfe10b312642bb490eb9 (patch)
tree914bf1a5c6cf12a2c64c829d9959c38e78f2b850 /meta-oe
parent85dc931097155fdd7f21180ee5927a1453fed035 (diff)
downloadmeta-openembedded-contrib-5add8e838f321eb4bb75cfe10b312642bb490eb9.tar.gz
libvncserver: Update to latest version
The latest release of libvncserver is almost two years old. A number of security fixes and enhancements have recently been committed. Since the repo is stable, point the recipe to the latest commit. libvncserver switched from autotools to cmake, so update the recipe as necessary, and add PACKAGECONFIG options to allow a more minimal build and install. Signed-off-by: Eddie James <eajames@linux.ibm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-graphics/libvncserver/libvncserver_0.9.11.bb25
-rw-r--r--meta-oe/recipes-graphics/libvncserver/libvncserver_git.bb23
2 files changed, 23 insertions, 25 deletions
diff --git a/meta-oe/recipes-graphics/libvncserver/libvncserver_0.9.11.bb b/meta-oe/recipes-graphics/libvncserver/libvncserver_0.9.11.bb
deleted file mode 100644
index 38dac06e64..0000000000
--- a/meta-oe/recipes-graphics/libvncserver/libvncserver_0.9.11.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION = "library for easy implementation of a RDP/VNC server"
-HOMEPAGE = "https://libvnc.github.io"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=361b6b837cad26c6900a926b62aada5f"
-
-DEPENDS += "zlib libsdl jpeg libpng gtk+ libgcrypt nettle gnutls gmp"
-
-PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
-PACKAGECONFIG[systemd] = ",,systemd"
-
-RDEPENDS_${PN} += "libpng gtk+ libgcrypt"
-
-inherit distro_features_check autotools binconfig pkgconfig
-
-REQUIRED_DISTRO_FEATURES = "x11"
-
-SRC_URI = "https://github.com/LibVNC/libvncserver/archive/LibVNCServer-${PV}.tar.gz"
-SRC_URI[md5sum] = "7f06104d5c009813e95142932c4ddb06"
-SRC_URI[sha256sum] = "193d630372722a532136fd25c5326b2ca1a636cbb8bf9bb115ef869c804d2894"
-
-S = "${WORKDIR}/${BPN}-LibVNCServer-${PV}"
-
-TARGET_LDFLAGS += "-lgcrypt"
diff --git a/meta-oe/recipes-graphics/libvncserver/libvncserver_git.bb b/meta-oe/recipes-graphics/libvncserver/libvncserver_git.bb
new file mode 100644
index 0000000000..25917756fc
--- /dev/null
+++ b/meta-oe/recipes-graphics/libvncserver/libvncserver_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "library for easy implementation of a RDP/VNC server"
+HOMEPAGE = "https://libvnc.github.io"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=361b6b837cad26c6900a926b62aada5f"
+
+PACKAGECONFIG ??= "gcrypt gnutls jpeg png ${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)} sdl zlib"
+PACKAGECONFIG[gcrypt] = ",,libgcrypt,libgcrypt"
+PACKAGECONFIG[gnutls] = ",,gnutls"
+PACKAGECONFIG[jpeg] = ",-DWITH_JPEG=OFF,jpeg"
+PACKAGECONFIG[openssl] = ",,openssl"
+PACKAGECONFIG[png] = ",-DWITH_PNG=OFF,libpng,libpng"
+PACKAGECONFIG[systemd] = ",,systemd"
+PACKAGECONFIG[sdl] = ",,libsdl2"
+PACKAGECONFIG[zlib] = ",,zlib"
+
+inherit cmake
+
+SRC_URI = "git://github.com/LibVNC/libvncserver"
+SRCREV = "f997b5a75fa171d79c5e568b7157fba83c8d8355"
+
+S = "${WORKDIR}/git"