aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2016-12-22 08:19:30 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-26 08:24:56 +0100
commit7787c56382818f25a079eb9c6a8d7839424b5afc (patch)
tree8fd74485b21e9c3f988bc72ef77b44733e4fdf23 /meta-oe/recipes-test
parent31c93c34aa56bab297257f7b3fab94cc89cbc323 (diff)
downloadmeta-openembedded-contrib-7787c56382818f25a079eb9c6a8d7839424b5afc.tar.gz
fwts: upgrade to 16.12.00 release
* update PV and SRCREV to match 16.12.00 release * refresh 0001-ignore-constant-logical-operand-warning-with-clang.patch Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-test')
-rw-r--r--meta-oe/recipes-test/fwts/fwts/0001-ignore-constant-logical-operand-warning-with-clang.patch92
-rw-r--r--meta-oe/recipes-test/fwts/fwts_git.bb4
2 files changed, 49 insertions, 47 deletions
diff --git a/meta-oe/recipes-test/fwts/fwts/0001-ignore-constant-logical-operand-warning-with-clang.patch b/meta-oe/recipes-test/fwts/fwts/0001-ignore-constant-logical-operand-warning-with-clang.patch
index ccfe580c14..a3cc1ff8e5 100644
--- a/meta-oe/recipes-test/fwts/fwts/0001-ignore-constant-logical-operand-warning-with-clang.patch
+++ b/meta-oe/recipes-test/fwts/fwts/0001-ignore-constant-logical-operand-warning-with-clang.patch
@@ -5,37 +5,37 @@ Subject: [PATCH] ignore constant-logical-operand warning with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
+ src/dmi/dmicheck/dmicheck.c | 3 +++
+ src/lib/src/fwts_acpi_tables.c | 5 +++++
src/uefi/uefirtauthvar/uefirtauthvar.c | 5 +++++
- 1 file changed, 5 insertions(+)
+ 3 files changed, 13 insertions(+)
-Index: git/src/uefi/uefirtauthvar/uefirtauthvar.c
-===================================================================
---- git.orig/src/uefi/uefirtauthvar/uefirtauthvar.c
-+++ git/src/uefi/uefirtauthvar/uefirtauthvar.c
-@@ -142,6 +142,9 @@ static int uefirtauthvar_deinit(fwts_fra
- return FWTS_OK;
- }
-
+diff --git a/src/dmi/dmicheck/dmicheck.c b/src/dmi/dmicheck/dmicheck.c
+index ecd98223..7fca4a64 100644
+--- a/src/dmi/dmicheck/dmicheck.c
++++ b/src/dmi/dmicheck/dmicheck.c
+@@ -209,6 +209,8 @@ static const char *uuid_patterns[] = {
+ "0A0A0A0A-0A0A-0A0A-0A0A-0A0A0A0A0A0A",
+ NULL,
+ };
+#pragma clang diagnostic push
-+#pragma clang diagnostic ignored "-Wconstant-logical-operand"
-+
- static int check_fw_support(fwts_framework *fw, uint64_t status)
- {
- if ((status == EFI_INVALID_PARAMETER) &&
-@@ -172,6 +175,8 @@ static int check_fw_support(fwts_framewo
- return FWTS_OK;
- }
++#pragma clang diagnostic ignored "-Wunneeded-internal-declaration"
+ static const fwts_chassis_type_map fwts_dmi_chassis_type[] = {
+ { "Invalid", FWTS_SMBIOS_CHASSIS_INVALID },
+@@ -245,6 +247,7 @@ static const fwts_chassis_type_map fwts_dmi_chassis_type[] = {
+ { "Convertible", FWTS_SMBIOS_CHASSIS_CONVERTIBLE },
+ { "Detachable", FWTS_SMBIOS_CHASSIS_DETACHABLE },
+ };
+#pragma clang diagnostic pop
-+
- /*
- * Set the created authenticated variable, AuthVarCreate,
- * and checking the data size and data.
-Index: git/src/lib/src/fwts_acpi_tables.c
-===================================================================
---- git.orig/src/lib/src/fwts_acpi_tables.c
-+++ git/src/lib/src/fwts_acpi_tables.c
-@@ -392,10 +392,14 @@ static int fwts_acpi_handle_fadt(
+
+ /* Remapping table from buggy version numbers to correct values */
+ static const fwts_dmi_version dmi_versions[] = {
+diff --git a/src/lib/src/fwts_acpi_tables.c b/src/lib/src/fwts_acpi_tables.c
+index 30b4060e..d5339bf7 100644
+--- a/src/lib/src/fwts_acpi_tables.c
++++ b/src/lib/src/fwts_acpi_tables.c
+@@ -394,10 +394,14 @@ static int fwts_acpi_handle_fadt(
/* Determine FACS addr and load it.
* Will ignore the missing FACS in the hardware-reduced mode.
*/
@@ -50,7 +50,7 @@ Index: git/src/lib/src/fwts_acpi_tables.c
if (result != FWTS_OK) {
if ((result == FWTS_NULL_POINTER) &&
fwts_acpi_is_reduced_hardware(fadt)) {
-@@ -414,6 +418,7 @@ static int fwts_acpi_handle_fadt(
+@@ -416,6 +420,7 @@ static int fwts_acpi_handle_fadt(
return FWTS_ERROR;
}
return FWTS_OK;
@@ -58,24 +58,26 @@ Index: git/src/lib/src/fwts_acpi_tables.c
}
/*
-Index: git/src/dmi/dmicheck/dmicheck.c
-===================================================================
---- git.orig/src/dmi/dmicheck/dmicheck.c
-+++ git/src/dmi/dmicheck/dmicheck.c
-@@ -209,6 +209,8 @@ static const char *uuid_patterns[] = {
- "0A0A0A0A-0A0A-0A0A-0A0A-0A0A0A0A0A0A",
- NULL,
- };
+diff --git a/src/uefi/uefirtauthvar/uefirtauthvar.c b/src/uefi/uefirtauthvar/uefirtauthvar.c
+index cdfd7aa3..001e8cc8 100644
+--- a/src/uefi/uefirtauthvar/uefirtauthvar.c
++++ b/src/uefi/uefirtauthvar/uefirtauthvar.c
+@@ -142,6 +142,9 @@ static int uefirtauthvar_deinit(fwts_framework *fw)
+ return FWTS_OK;
+ }
+
+#pragma clang diagnostic push
-+#pragma clang diagnostic ignored "-Wunneeded-internal-declaration"
++#pragma clang diagnostic ignored "-Wconstant-logical-operand"
++
+ static int check_fw_support(fwts_framework *fw, uint64_t status)
+ {
+ if ((status == EFI_INVALID_PARAMETER) &&
+@@ -172,6 +175,8 @@ static int check_fw_support(fwts_framework *fw, uint64_t status)
+ return FWTS_OK;
+ }
- static const fwts_chassis_type_map fwts_dmi_chassis_type[] = {
- { "Invalid", FWTS_SMBIOS_CHASSIS_INVALID },
-@@ -245,6 +247,7 @@ static const fwts_chassis_type_map fwts_
- { "Convertible", FWTS_SMBIOS_CHASSIS_CONVERTIBLE },
- { "Detachable", FWTS_SMBIOS_CHASSIS_DETACHABLE },
- };
+#pragma clang diagnostic pop
-
- /* Remapping table from buggy version numbers to correct values */
- static const fwts_dmi_version dmi_versions[] = {
++
+ /*
+ * Set the created authenticated variable, AuthVarCreate,
+ * and checking the data size and data.
diff --git a/meta-oe/recipes-test/fwts/fwts_git.bb b/meta-oe/recipes-test/fwts/fwts_git.bb
index b04be021bf..82ed5ecf05 100644
--- a/meta-oe/recipes-test/fwts/fwts_git.bb
+++ b/meta-oe/recipes-test/fwts/fwts_git.bb
@@ -5,9 +5,9 @@ HOMEPAGE = "https://wiki.ubuntu.com/Kernel/Reference/fwts"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=31da590f3e9f3bd34dcdb9e4db568519"
-PV = "16.09.00"
+PV = "16.12.00"
-SRCREV = "15386283ad55e2a5b9366c1f43f4531ef79b01cb"
+SRCREV = "d38fced7db86e5483d5c2e634ee1eec98620d5b8"
SRC_URI = "git://kernel.ubuntu.com/hwe/fwts.git \
file://0001-ignore-constant-logical-operand-warning-with-clang.patch \
"