aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2023-02-21 16:26:29 +0100
committerKhem Raj <raj.khem@gmail.com>2023-02-22 01:07:43 -0800
commita6833f471fc1d10ba4b0375b547e0e8f913c3500 (patch)
tree241c7635d8c5404a815de563015c8d6e713b5365 /meta-oe/recipes-support
parentd37abd5f8cef85b15506ac667e0be4b97d9dba2b (diff)
downloadmeta-openembedded-contrib-a6833f471fc1d10ba4b0375b547e0e8f913c3500.tar.gz
appstream: update 0.15.5 -> 0.16.1
Version 0.16.1 ~~~~~~~~~~~~~~ Released: 2023-02-10 Notes: * This is a bugfix-only release to primarily address an issue introduced in v0.15.6 that caused any clients using GIR bindings to crash after a while. Specification: * docs: Clarify the locations where catalog icons should be placed * spec: Expand documentation for <issue> elements * spec: Mention that <issues> is not part of the description * spec: Give some guidance about tone in release descriptions Bugfixes: * Fix binding helper macro to behave correctly if a function is passed directly * Override-merge icons and provided items correctly * tests: Ensure locale is C.UTF-8 in pool tests Miscellaneous: * release: Add sanity checks at beginning of each function Contributors: Corentin Noël, Matthias Klumpp, Pablo Correa Gómez, Philip Withnall Version 0.16.0 ~~~~~~~~~~~~~~ Released: 2023-01-26 Features: * pool: Offer API to look up components by bundles * Bump format version to 0.16 * Add new AsSystemInfo to read information about the current OS and device * Add helper to get device names from a modalias * Implement support for external release metadata * Add validation support for external release metadata * compose: Validate external release metadata used for the catalog as well * its: Add rule for standalone release metadata * Add function to test if an AsRelation is satisfied on the current system * cli: Add command to list category contents * cli: Display colored checkmarks if possible * cli: Add new is-satisfied check to test relations from the command-line * cli: Add Markdown export support for metainfo-to-news * qt: Add support for SystemInfo & relation satisfication checks Specification: * spec: Specify a metadata format for external release descriptions Bugfixes: * Fix build with Clang 15 * Give a better error message if trying to list too many categories * Adjust documentation of AsPool.get_components_by_categories to reflect reality * validator: Validate merge component catalog data properly again Miscellaneous: * Consistently name catalog metadata as such everywhere Contributors: Aleix Pol, Matthias Klumpp, Rafael Fontenelle Version 0.15.6 ~~~~~~~~~~~~~~ Released: 2022-12-22 Features: * qt: Add API for ContentRating descriptions and ratingIds * Add some coccinelle semantic patches for common style issues * compose: Allow building without SVG support (for bootstrap only) * validator: Check for nodes that are text nodes even though they shouldn't be * validator: Extend validation for custom tag * validator: Improve Screenshot validation Specification: * docs: Fix typos in <extends> documentation Bugfixes: * validator: internat: Don't allow bandwidth_mbitps when value is offline-only * validator: Fix timestamp validation * validator: Allow release descriptions to start with punctuation * compose: Only add no-metainfo tag if component isn't already ignored * compose: Show better error in AscImage if compose was build without rsvg * Add a hack to clarify proper PtrArray element ownership for language bindings * qt: Port away from deprecated QDateTime API * qt: Deprecate Component::requires * qt: Fix warning * qt: Fix stringListToCharArray and Pool::componentsByCategories * qt: Port away from deprecated foreach * as-review: Add a typedef for property enums * as-review: Install properties at once rather than individually * as-review: Specify G_PARAM_STATIC_STRINGS for properties * as-review: Emit GObject::notify on property value changes * as-review: Add missing property for as_review_{get,set}_priority() * ascli: fix NULL pointer dereference Miscellaneous: * docs: Split releases specification into its own section * style: Make code easier to read by using helper macros in all places * Make some compiler warnings fatal unconditionally Contributors: Aleix Pol, JakobDev, Matthias Klumpp, Nicolas Fella, Philip Withnall, r-ricci, Will Thompson Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/appstream/appstream_0.16.1.bb (renamed from meta-oe/recipes-support/appstream/appstream_0.15.5.bb)8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/appstream/appstream_0.15.5.bb b/meta-oe/recipes-support/appstream/appstream_0.16.1.bb
index e8637b5eef..50d8cdb4c2 100644
--- a/meta-oe/recipes-support/appstream/appstream_0.15.5.bb
+++ b/meta-oe/recipes-support/appstream/appstream_0.16.1.bb
@@ -11,7 +11,6 @@ DEPENDS = " \
gperf-native \
glib-2.0 \
libyaml \
- libstemmer \
libxml2 \
libxmlb \
libxslt-native \
@@ -26,10 +25,15 @@ GIR_MESON_OPTION = ""
SRC_URI = "https://www.freedesktop.org/software/appstream/releases/AppStream-${PV}.tar.xz"
SRC_URI:append:class-target = " file://0001-fix-crosscompile.patch"
-SRC_URI[sha256sum] = "cb15ed62cc2729683879a2dbf98c0a3267ea2b4d57bba6bc55e70a25500e04c2"
+SRC_URI[sha256sum] = "77e274e163db1f0a1bec8f4134b1d0f31e9c0a8c54cd37f724a7d30a71cf41d2"
S = "${WORKDIR}/AppStream-${PV}"
+PACKAGECONFIG ?= "stemming ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
+
+PACKAGECONFIG[systemd] = "-Dsystemd=true,-Dsystemd=false,systemd"
+PACKAGECONFIG[stemming] = "-Dstemming=true,-Dstemming=false,libstemmer"
+
FILES:${PN} += "${datadir}"
EXTRA_OEMESON:class-target += "--cross-file=${WORKDIR}/meson-${PN}.cross"