aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-04-13 08:41:17 -0700
committerKhem Raj <raj.khem@gmail.com>2022-04-13 19:21:41 -0700
commit6892fc010ab916886d7c75c121a2ad0866c9d39a (patch)
tree32a12cc98b7657c5cb5de1116d0ea7a8f71bf768 /meta-oe/recipes-support
parent5288d38ee66667463750caf2d0ed1863e52364ef (diff)
downloadmeta-openembedded-contrib-6892fc010ab916886d7c75c121a2ad0866c9d39a.tar.gz
gnulib: Do not use git operations to install the sources
git operations have started to fail with errors like | fatal: unsafe repository ('/mnt/b/yoe/master/build/tmp/work/riscv64-yoe-linux-musl/gnulib/2018-03-07.03-r0/git' is owned by someon e else) | To add an exception for this directory, call: | | git config --global --add safe.directory /mnt/b/yoe/master/build/tmp/work/riscv64-yoe-linux-musl/gnulib/2018-03-07.03-r0/git This is after git has fixed a CVE in 2.35+ see [1] [1] https://github.com/actions/checkout/issues/760 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb11
1 files changed, 4 insertions, 7 deletions
diff --git a/meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb b/meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb
index 2aab68e6a5..a27968079e 100644
--- a/meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb
+++ b/meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb
@@ -13,18 +13,15 @@ LICENSE = "LGPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=56a22a6e5bcce45e2c8ac184f81412b5"
SRCREV = "0d6e3307bbdb8df4d56043d5f373eeeffe4cbef3"
-SRC_URI = "git://git.sv.gnu.org/gnulib.git;branch=master \
+SRC_URI = "git://git.savannah.gnu.org/git/gnulib.git;branch=master \
"
S = "${WORKDIR}/git"
-inherit utils
-
do_install () {
- cd ${S}
- check_git_config
- git checkout master
- git clone ${S} ${D}/${datadir}/gnulib
+ install -d ${D}/${datadir}/gnulib
+ cp --no-preserve=ownership --recursive ${S}/* ${D}/${datadir}/gnulib/
+ cp --no-preserve=ownership --recursive ${S}/.git ${D}/${datadir}/gnulib/
}
do_patch[noexec] = "1"