aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-04-19 07:56:55 -0700
committerKhem Raj <raj.khem@gmail.com>2022-04-19 08:22:50 -0700
commit33f4142dff5635eb3fc62ee5870387fa5cc6028b (patch)
tree2be24f07d5963906d922d4b87ad9a03bafeea657 /meta-oe/recipes-support
parent6ece0f38b01fa70a2ee13477045c6d887cc26fa5 (diff)
downloadmeta-openembedded-contrib-33f4142dff5635eb3fc62ee5870387fa5cc6028b.tar.gz
libcereal: Link libatomics with gcc as well
Since gcc-12, gcc is also emitting calls to 64bit atomics Fixes unittests/CMakeFiles/test_atomic.dir/atomic.cpp.o:/usr/include/c++/12.0.1/atomic:285: more undefined references to `__atomic_load_8' follow collect2: error: ld returned 1 exit status Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/libcereal/libcereal_1.3.2.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/libcereal/libcereal_1.3.2.bb b/meta-oe/recipes-support/libcereal/libcereal_1.3.2.bb
index 0bb06c1d1f..fc4fad708a 100644
--- a/meta-oe/recipes-support/libcereal/libcereal_1.3.2.bb
+++ b/meta-oe/recipes-support/libcereal/libcereal_1.3.2.bb
@@ -26,8 +26,8 @@ S = "${WORKDIR}/git"
inherit cmake pkgconfig ptest
-LIBATOMIC:mips:toolchain-clang = "${@bb.utils.contains('PTEST_ENABLED', '1', '-DCEREAL_THREAD_LIBS="-latomic"', '', d)}"
-LIBATOMIC:riscv32:toolchain-clang = "${@bb.utils.contains('PTEST_ENABLED', '1', '-DCEREAL_THREAD_LIBS="-latomic"', '', d)}"
+LIBATOMIC:mips = "${@bb.utils.contains('PTEST_ENABLED', '1', '-DCEREAL_THREAD_LIBS="-latomic"', '', d)}"
+LIBATOMIC:riscv32 = "${@bb.utils.contains('PTEST_ENABLED', '1', '-DCEREAL_THREAD_LIBS="-latomic"', '', d)}"
PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'with-tests', '', d)}"
PACKAGECONFIG[with-tests] = "-DWITH_WERROR=OFF -DBUILD_TESTS=ON ${LIBATOMIC},,"