aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-01-17 23:21:26 -0800
committerKhem Raj <raj.khem@gmail.com>2023-01-21 10:02:02 -0800
commit6f3ded8f27a60a7e8d99d1ba600f05d6a2755716 (patch)
treec37cf52eddae4336ae909c53caaa428a7f16f7ba /meta-oe/recipes-support
parent195c2045fdf8b9ba8114651efd849bccc9308d1f (diff)
downloadmeta-openembedded-contrib-6f3ded8f27a60a7e8d99d1ba600f05d6a2755716.tar.gz
ssiapi: Use c++14 standard
It depends on std::auto_ptr which is gone with c++17 therefore pin to c++14 until auto_ptr is replaced with something else e.g. unique_ptr Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/ssiapi/ssiapi_1.3.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/ssiapi/ssiapi_1.3.0.bb b/meta-oe/recipes-support/ssiapi/ssiapi_1.3.0.bb
index 13ed7570b1..bf9de31f84 100644
--- a/meta-oe/recipes-support/ssiapi/ssiapi_1.3.0.bb
+++ b/meta-oe/recipes-support/ssiapi/ssiapi_1.3.0.bb
@@ -29,6 +29,8 @@ S ="${WORKDIR}/${BPN}.${PV}"
inherit autotools
+CXXFLAGS += "-std=gnu++14"
+
do_configure:prepend(){
${S}/autogen.sh
}