summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-17 12:51:16 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-17 12:53:21 +0200
commit90bd2e80a7e8a5279831b95b04b9c45733328b71 (patch)
treebcf71779a7ec75a17a6380b33899027cdc4b6465 /meta-oe/recipes-support
parent059bd1cc7b1488ec88efcdfa44a2fa9c14800b6c (diff)
downloadmeta-openembedded-contrib-90bd2e80a7e8a5279831b95b04b9c45733328b71.tar.gz
ntpd 4.2.6p3: make default configfile actually work
also remove machine overrides
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/ntp/files/hipox/ntp.conf13
-rwxr-xr-xmeta-oe/recipes-support/ntp/files/hipox/ntpd62
-rw-r--r--meta-oe/recipes-support/ntp/files/ntp.conf2
-rw-r--r--meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb2
4 files changed, 2 insertions, 77 deletions
diff --git a/meta-oe/recipes-support/ntp/files/hipox/ntp.conf b/meta-oe/recipes-support/ntp/files/hipox/ntp.conf
deleted file mode 100644
index 57e585c175..0000000000
--- a/meta-oe/recipes-support/ntp/files/hipox/ntp.conf
+++ /dev/null
@@ -1,13 +0,0 @@
-# This is the most basic ntp configuration file
-# The driftfile must remain in a place specific to this
-# machine - it records the machine specific clock error
-driftfile /etc/ntp.drift
-# This obtains a random server which will be close
-# (in IP terms) to the machine. Add other servers
-# as required, or change this.
-#server pool.ntp.org
-# Using local hardware clock as fallback
-server 127.127.1.0
-fudge 127.127.1.0 stratum 14
-# Defining a default security setting
-restrict default nomodify nopeer
diff --git a/meta-oe/recipes-support/ntp/files/hipox/ntpd b/meta-oe/recipes-support/ntp/files/hipox/ntpd
deleted file mode 100755
index 7d2cd34cdf..0000000000
--- a/meta-oe/recipes-support/ntp/files/hipox/ntpd
+++ /dev/null
@@ -1,62 +0,0 @@
-#! /bin/sh
-#
-# ntpd init.d script for ntpdc from ntp.isc.org
-test -x /usr/bin/ntpd -a -r /etc/ntp.conf || exit 0
-# rcS contains TICKADJ
-test -r /etc/default/rcS && . /etc/default/rcS
-
-# Functions to do individual actions
-settick(){
- # If TICKADJ is set we *must* adjust it before we start, because the
- # driftfile relies on the correct setting
- test -n "$TICKADJ" -a -x /usr/bin/tickadj && {
- echo -n "Setting tick to $TICKADJ: "
- /usr/bin/tickadj "$TICKADJ"
- echo "done"
- }
-}
-startdaemon(){
- # The -g option allows ntpd to step the time to correct it just
- # once. The daemon will exit if the clock drifts too much after
- # this. If ntpd seems to disappear after a while assume TICKADJ
- # above is set to a totally incorrect value.
- echo -n "Starting ntpd: "
- start-stop-daemon --start -x /usr/bin/ntpd -- -p /var/run/ntp.pid "$@"
- echo "done"
-}
-stopdaemon(){
- echo -n "Stopping ntpd: "
- start-stop-daemon --stop -p /var/run/ntp.pid
- echo "done"
-}
-
-case "$1" in
- start)
- settick
- startdaemon -g -x
- ;;
- stop)
- stopdaemon
- ;;
- force-reload)
- stopdaemon
- settick
- startdaemon -g -x
- ;;
- restart)
- # Don't reset the tick here
- stopdaemon
- startdaemon -g -x
- ;;
- reload)
- # Must do this by hand, but don't do -g
- stopdaemon
- startdaemon -x
- ;;
- *)
- echo "Usage: ntpd { start | stop | restart | reload }" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/meta-oe/recipes-support/ntp/files/ntp.conf b/meta-oe/recipes-support/ntp/files/ntp.conf
index 02a44b0d01..5964828708 100644
--- a/meta-oe/recipes-support/ntp/files/ntp.conf
+++ b/meta-oe/recipes-support/ntp/files/ntp.conf
@@ -10,4 +10,4 @@ server pool.ntp.org
server 127.127.1.0
fudge 127.127.1.0 stratum 14
# Defining a default security setting
-restrict default nomodify nopeer
+restrict default
diff --git a/meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb b/meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb
index f64f6f6d92..590eed15a8 100644
--- a/meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb
+++ b/meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb
@@ -1,6 +1,6 @@
require ntp.inc
-PR = "r1"
+PR = "r2"
SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/${P}.tar.gz \
file://tickadj.c.patch \