aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-05-10 14:55:11 +0300
committerKhem Raj <raj.khem@gmail.com>2019-05-10 14:07:54 -0700
commit9fa7848415e8a074afeede2dda52628f76ef1954 (patch)
treec5d2aa4e2a84a72b8285ad3a9af1252f2cdd9cf5 /meta-oe/recipes-support
parent772421e9e90e0a4c9654fae5fafed54efc15ace2 (diff)
downloadmeta-openembedded-contrib-9fa7848415e8a074afeede2dda52628f76ef1954.tar.gz
liboop: Upgrade 1.0 -> 1.0.1
Remove patches applied upstream. Update to the current homepage. Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/liboop/liboop/explicit_linking.patch20
-rw-r--r--meta-oe/recipes-support/liboop/liboop/new-readline-typedef.patch11
-rw-r--r--meta-oe/recipes-support/liboop/liboop/read_bugfixes.patch40
-rw-r--r--meta-oe/recipes-support/liboop/liboop/tcl_dev.patch11
-rw-r--r--meta-oe/recipes-support/liboop/liboop_1.0.1.bb (renamed from meta-oe/recipes-support/liboop/liboop_1.0.bb)9
5 files changed, 3 insertions, 88 deletions
diff --git a/meta-oe/recipes-support/liboop/liboop/explicit_linking.patch b/meta-oe/recipes-support/liboop/liboop/explicit_linking.patch
deleted file mode 100644
index 05d3bf6f44..0000000000
--- a/meta-oe/recipes-support/liboop/liboop/explicit_linking.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -51,7 +51,7 @@ noinst_PROGRAMS = test-oop
-
- test_oop_SOURCES = test-oop.c
- test_oop_CFLAGS = $(GLIB2_CFLAGS) $(GLIB_INCLUDES) $(TCL_INCLUDES) $(WWW_INCLUDES)
--test_oop_LDADD = $(lib_LTLIBRARIES)
-+test_oop_LDADD = $(lib_LTLIBRARIES) $(GLIB2_LIBS) $(ADNS_LIBS) $(TCL_LIBS) $(READLINE_LIBS)
-
- release: dist
- gzip -dc $(PACKAGE)-$(VERSION).tar.gz | bzip2 -9 \
---- a/liboop-glib2.pc.in
-+++ b/liboop-glib2.pc.in
-@@ -7,5 +7,5 @@ Name: liboop-glib2
- Description: Event loop management library (GLIB2 support)
- Version: @VERSION@
- Requires: liboop = @VERSION@ glib-2.0
--Libs: -L${libdir} -loop-glib2
-+Libs: -L${libdir} -loop-glib2 @GLIB2_LIBS@
- Cflags: -D_REENTRANT -I${includedir}
diff --git a/meta-oe/recipes-support/liboop/liboop/new-readline-typedef.patch b/meta-oe/recipes-support/liboop/liboop/new-readline-typedef.patch
deleted file mode 100644
index 0a0242032f..0000000000
--- a/meta-oe/recipes-support/liboop/liboop/new-readline-typedef.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/test-oop.c
-+++ b/test-oop.c
-@@ -180,7 +180,7 @@ static void *stop_readline(oop_source *s
- static void add_readline(oop_source *src) {
- rl_callback_handler_install(
- (char *) "> ", /* readline isn't const-correct */
-- (VFunction *) on_readline);
-+ (rl_vcpfunc_t *) on_readline);
- oop_readline_register(src);
- src->on_signal(src,SIGQUIT,stop_readline,NULL);
- }
diff --git a/meta-oe/recipes-support/liboop/liboop/read_bugfixes.patch b/meta-oe/recipes-support/liboop/liboop/read_bugfixes.patch
deleted file mode 100644
index 1880a241ac..0000000000
--- a/meta-oe/recipes-support/liboop/liboop/read_bugfixes.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From: Ian Jackson <ijackson@chiark.greenend.org.uk>
-Applied-Upstream: no
-Bug-Debian: http://bugs.debian.org/579604
-Subject: oop-read.h bugfixes
-
-Some years ago I contributed a feature for reading lines and records
-to liboop: oop-read.h and read.c. Since it took a while for that
-feature to make it into distributed versions, for a long time I've
-been using my own copy of the source file. It seems that I fixed a
-couple of bugs in my copy which are still in the Debian package. I
-can't find any record of me having told anyone about them and now I
-find that 1.0-6 still has the bugs.
-
-There are two fixes:
- * Initialise "rd->discard" properly
- * Avoid rd->neednotcheck becoming negative
-
---- a/read.c
-+++ b/read.c
-@@ -114,6 +114,7 @@ oop_read *oop_rd_new(oop_source *oop, oo
- rd->allocbuf= 0;
- rd->used= 0;
- rd->alloc= buf ? bufsz : 0;
-+ rd->discard= 0;
- rd->neednotcheck= 0;
- rd->displacedchar= -1;
- rd->style= *OOP_RD_STYLE_IMMED;
-@@ -235,7 +236,11 @@ static void *on_process(oop_source *oop,
-
- if (rd->discard) {
- rd->used -= rd->discard;
-- rd->neednotcheck -= rd->discard;
-+ if (rd->neednotcheck > rd->discard) {
-+ rd->neednotcheck -= rd->discard;
-+ } else {
-+ rd->neednotcheck= 0;
-+ }
- memmove(buf, buf + rd->discard, rd->used);
- rd->discard= 0;
- }
diff --git a/meta-oe/recipes-support/liboop/liboop/tcl_dev.patch b/meta-oe/recipes-support/liboop/liboop/tcl_dev.patch
index e738be54ca..e00cf80141 100644
--- a/meta-oe/recipes-support/liboop/liboop/tcl_dev.patch
+++ b/meta-oe/recipes-support/liboop/liboop/tcl_dev.patch
@@ -1,14 +1,3 @@
---- a/configure
-+++ b/configure
-@@ -19935,7 +19935,7 @@
- fi
-
- if test xno != x$with_tcl; then
-- for version in 8.4 8.3 8.2 8.1 8.0 ; do
-+ for version in "" 8.4 8.3 8.2 8.1 8.0 ; do
- CPPFLAGS="$save_cppflags -I/usr/include/tcl$version"
- as_ac_Lib=`echo "ac_cv_lib_tcl$version''_Tcl_Main" | $as_tr_sh`
- echo "$as_me:$LINENO: checking for Tcl_Main in -ltcl$version" >&5
--- a/configure.ac
+++ b/configure.ac
@@ -71,7 +71,7 @@
diff --git a/meta-oe/recipes-support/liboop/liboop_1.0.bb b/meta-oe/recipes-support/liboop/liboop_1.0.1.bb
index 82818c2424..8ba3f72b76 100644
--- a/meta-oe/recipes-support/liboop/liboop_1.0.bb
+++ b/meta-oe/recipes-support/liboop/liboop_1.0.1.bb
@@ -1,17 +1,14 @@
DESCRIPTION = "Liboop is a low-level event loop management library for POSIX-based operating systems"
-HOMEPAGE = "http://liboop.org/"
+HOMEPAGE = "http://www.lysator.liu.se/liboop/"
LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=8b54f38ccbd44feb80ab90e01af8b700"
SRC_URI = "http://ftp.debian.org/debian/pool/main/libo/liboop/liboop_${PV}.orig.tar.gz \
- file://read_bugfixes.patch \
- file://explicit_linking.patch \
file://tcl_dev.patch \
- file://new-readline-typedef.patch \
"
-SRC_URI[md5sum] = "36cb971047d3af02369446f5e0b315a2"
-SRC_URI[sha256sum] = "34d83c6e0f09ee15cb2bc3131e219747c3b612bb57cf7d25318ab90da9a2d97c"
+SRC_URI[md5sum] = "f2b3dff17355fd9a6e2229caca8993f0"
+SRC_URI[sha256sum] = "56af16ad65e7397dadc8268e37ff6f67431db390c60c75e21a33e12b0e0d17e0"
PACKAGECONFIG ?= ""
PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"