aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-03-07 11:12:18 -0500
committerArmin Kuster <akuster808@gmail.com>2018-03-12 10:01:16 -0700
commitd93df171bec4b4d9bb4fdafb62f3ffd0d9d4b7f2 (patch)
tree53fe791584f44c42ca0bdade9152ea3442b2ff23 /meta-oe/recipes-support
parentaa997c97b30d016817dbf471536989c0e1b589ef (diff)
downloadmeta-openembedded-contrib-d93df171bec4b4d9bb4fdafb62f3ffd0d9d4b7f2.tar.gz
gnulib: use deltask instead of noexec
When building an image which included 'netcf' I saw the following warning which is followed by a python backtrace: WARNING: cube-dom0-0.6-r0 do_rootfs: \ Manifest .../manifest-x86_64_x86_64-nativesdk-gnulib.package_write_rpm \ not found in genericx86_64 core2-64 x86_64 allarch x86_64_x86_64-nativesdk \ (variant '')? >From this we find that the 'gnulib' package would fail the manifest crosscheck for the 'package_write_rpm' task. By switching from 'noexec' to 'deltask' for this task (and its "siblings") we completely remove the task and thus there is not crosscheck to fail. NOTE that there is a pending merge which will change the backtrace for a proper ERROR: [package_manager.py: Print offending package instead of non-sense trace] Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/gnulib/gnulib_2017-08-20.18.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/gnulib/gnulib_2017-08-20.18.bb b/meta-oe/recipes-support/gnulib/gnulib_2017-08-20.18.bb
index b505ac18dd..b72ffa9a19 100644
--- a/meta-oe/recipes-support/gnulib/gnulib_2017-08-20.18.bb
+++ b/meta-oe/recipes-support/gnulib/gnulib_2017-08-20.18.bb
@@ -29,8 +29,8 @@ do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_package[noexec] = "1"
do_packagedata[noexec] = "1"
-do_package_write_ipk[noexec] = "1"
-do_package_write_deb[noexec] = "1"
-do_package_write_rpm[noexec] = "1"
+deltask package_write_ipk
+deltask package_write_deb
+deltask package_write_rpm
BBCLASSEXTEND = "native"