aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-03-06 18:35:15 -0800
committerArmin Kuster <akuster808@gmail.com>2018-03-12 09:59:34 -0700
commitcf50e1f47d9d4329406c7c8cb8c1cbe9e310367f (patch)
treefca7734e84afd86a66c959a5a4038c758b3c9af8 /meta-oe/recipes-support
parent308e19e2d8a86ee07da974806d5833ff619450fd (diff)
downloadmeta-openembedded-contrib-cf50e1f47d9d4329406c7c8cb8c1cbe9e310367f.tar.gz
xrdp: remove fuse from depend and move to PACKAGECONFIG
fuse is in meta-filesystems Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/xrdp/xrdp_0.9.4.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/xrdp/xrdp_0.9.4.bb b/meta-oe/recipes-support/xrdp/xrdp_0.9.4.bb
index 671a251962..3ef7c9853f 100644
--- a/meta-oe/recipes-support/xrdp/xrdp_0.9.4.bb
+++ b/meta-oe/recipes-support/xrdp/xrdp_0.9.4.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=72cfbe4e7bd33a0a1de9630c91195c21 \
inherit distro_features_check autotools pkgconfig useradd systemd
-DEPENDS = "openssl virtual/libx11 libxfixes libxrandr libpam nasm-native fuse"
+DEPENDS = "openssl virtual/libx11 libxfixes libxrandr libpam nasm-native"
REQUIRED_DISTRO_FEATURES = "x11 pam"
@@ -24,6 +24,9 @@ PV = "0.9.4+git${SRCPV}"
S = "${WORKDIR}/git"
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[fuse] = " --enable-fuse, --disable-fuse, fuse"
+
USERADD_PACKAGES = "${PN}"
GROUPADD_PARAM_${PN} = "--system xrdp"
USERADD_PARAM_${PN} = "--system --home /var/run/xrdp -g xrdp \
@@ -37,7 +40,7 @@ FILES_${PN}-dev += "${libdir}/xrdp/libcommon.so \
${libdir}/xrdp/libscp.so \
${libdir}/xrdp/libxrdpapi.so "
-EXTRA_OECONF = "--enable-pam-config=suse --enable-fuse"
+EXTRA_OECONF = "--enable-pam-config=suse"
do_configure_prepend() {
cd ${S}