aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2017-10-26 13:25:14 -0700
committerArmin Kuster <akuster808@gmail.com>2018-03-01 16:10:35 -0800
commit036b3e794650cfc92f2f983d860ce93575198b57 (patch)
treea3c238eefa863226c5d5b3e4fc496198a0f5cd8f /meta-oe/recipes-support
parentb836c5b810898cf51baa012c8debe816a715717a (diff)
downloadmeta-openembedded-contrib-036b3e794650cfc92f2f983d860ce93575198b57.tar.gz
sqlite: move to recipes-dbs
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/sqlite/sqlite-2.8.17/0001-shell.c-Fix-format-not-a-string-literal-warning.patch32
-rw-r--r--meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch32
-rw-r--r--meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_no_tcl.patch20
-rw-r--r--meta-oe/recipes-support/sqlite/sqlite-2.8.17/sqlite.pc12
-rw-r--r--meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb61
5 files changed, 0 insertions, 157 deletions
diff --git a/meta-oe/recipes-support/sqlite/sqlite-2.8.17/0001-shell.c-Fix-format-not-a-string-literal-warning.patch b/meta-oe/recipes-support/sqlite/sqlite-2.8.17/0001-shell.c-Fix-format-not-a-string-literal-warning.patch
deleted file mode 100644
index c5d7c0c81a..0000000000
--- a/meta-oe/recipes-support/sqlite/sqlite-2.8.17/0001-shell.c-Fix-format-not-a-string-literal-warning.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 443980ddc82fb40e2e1f9544f2be169bd23dd246 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sat, 17 Jun 2017 16:49:24 -0700
-Subject: [PATCH] shell.c: Fix format not a string literal warning
-
-src/shell.c:695:20: error: format not a string literal and no format arguments [-Werror=format-security]
-| fprintf(stderr,zHelp);
-| ^~~~~
-
-Upstream-Status: Pending
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/shell.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/shell.c b/src/shell.c
-index bb46c49..3c6fe0f 100644
---- a/src/shell.c
-+++ b/src/shell.c
-@@ -692,7 +692,7 @@ static int do_meta_command(char *zLine, struct callback_data *p){
- }else
-
- if( c=='h' && strncmp(azArg[0], "help", n)==0 ){
-- fprintf(stderr,zHelp);
-+ fprintf(stderr, "%s", zHelp);
- }else
-
- if( c=='i' && strncmp(azArg[0], "indices", n)==0 && nArg>1 ){
---
-2.13.1
-
diff --git a/meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch b/meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch
deleted file mode 100644
index 914422f1df..0000000000
--- a/meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -urN sqlite-2.8.17.orig/main.mk sqlite-2.8.17/main.mk
---- sqlite-2.8.17.orig/main.mk 2005-04-23 22:43:23.000000000 +0000
-+++ sqlite-2.8.17/main.mk 2009-04-02 20:10:36.000000000 +0000
-@@ -139,7 +139,7 @@
- # This is the default Makefile target. The objects listed here
- # are what get build when you type just "make" with no arguments.
- #
--all: sqlite.h config.h libsqlite.a sqlite$(EXE)
-+all: sqlite.h config.h libsqlite.so sqlite$(EXE)
-
- # Generate the file "last_change" which contains the date of change
- # of the most recently modified source code file
-@@ -148,13 +148,12 @@
- cat $(SRC) | grep '$$Id: ' | sort +4 | tail -1 \
- | awk '{print $$5,$$6}' >last_change
-
--libsqlite.a: $(LIBOBJ)
-- $(AR) libsqlite.a $(LIBOBJ)
-- $(RANLIB) libsqlite.a
--
--sqlite$(EXE): $(TOP)/src/shell.c libsqlite.a sqlite.h
-- $(TCCX) $(READLINE_FLAGS) -o sqlite$(EXE) $(TOP)/src/shell.c \
-- libsqlite.a $(LIBREADLINE) $(THREADLIB)
-+libsqlite.so: $(LIBOBJ)
-+ $(CC) $(LDFLAGS) -shared -o libsqlite.so -Wl,-soname,libsqlite.so.0 $(LIBOBJ)
-+
-+sqlite$(EXE): $(TOP)/src/shell.c libsqlite.so sqlite.h
-+ $(TCCX) $(LDFLAGS) $(READLINE_FLAGS) -o sqlite$(EXE) $(TOP)/src/shell.c \
-+ -lsqlite $(LIBREADLINE) $(THREADLIB)
-
- sqlite_analyzer$(EXE): $(TOP)/src/tclsqlite.c libsqlite.a $(TESTSRC) \
- $(TOP)/tool/spaceanal.tcl
diff --git a/meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_no_tcl.patch b/meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_no_tcl.patch
deleted file mode 100644
index b84b6486ef..0000000000
--- a/meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_no_tcl.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -bur sqlite-2.8.17~orig/main.mk sqlite-2.8.17/main.mk
---- sqlite-2.8.17~orig/main.mk 2006-02-13 04:09:33.000000000 -0600
-+++ sqlite-2.8.17/main.mk 2006-02-13 04:15:42.000000000 -0600
-@@ -58,7 +58,7 @@
- expr.o func.o hash.o insert.o \
- main.o opcodes.o os.o pager.o parse.o pragma.o printf.o random.o \
- select.o table.o tokenize.o trigger.o update.o util.o \
-- vacuum.o vdbe.o vdbeaux.o where.o tclsqlite.o
-+ vacuum.o vdbe.o vdbeaux.o where.o
-
- # All of the source code files.
- #
-@@ -91,7 +91,6 @@
- $(TOP)/src/sqlite.h.in \
- $(TOP)/src/sqliteInt.h \
- $(TOP)/src/table.c \
-- $(TOP)/src/tclsqlite.c \
- $(TOP)/src/tokenize.c \
- $(TOP)/src/trigger.c \
- $(TOP)/src/update.c \
diff --git a/meta-oe/recipes-support/sqlite/sqlite-2.8.17/sqlite.pc b/meta-oe/recipes-support/sqlite/sqlite-2.8.17/sqlite.pc
deleted file mode 100644
index 6bc742eecb..0000000000
--- a/meta-oe/recipes-support/sqlite/sqlite-2.8.17/sqlite.pc
+++ /dev/null
@@ -1,12 +0,0 @@
-# Package Information for pkg-config
-
-prefix=/usr
-exec_prefix=${prefix}
-libdir=${exec_prefix}/lib
-includedir=${prefix}/include
-
-Name: SQLite
-Description: SQL database engine
-Version: 2.8.17
-Libs: -L${libdir} -lsqlite
-Cflags: -I${includedir}
diff --git a/meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb b/meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb
deleted file mode 100644
index 501c0e3e77..0000000000
--- a/meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb
+++ /dev/null
@@ -1,61 +0,0 @@
-SUMMARY = "An Embeddable SQL Database Engine"
-HOMEPAGE = "http://www.sqlite.org/"
-SECTION = "libs"
-DEPENDS = "readline ncurses"
-LICENSE = "PD"
-LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=10;md5=e98469a8efa024a38ad5b2e4b92f4a96"
-
-PR = "r7"
-
-SRC_URI = "http://www.hwaci.com/sw/sqlite/sqlite-${PV}.tar.gz \
- file://mainmk_build_dynamic.patch \
- file://mainmk_no_tcl.patch \
- file://sqlite.pc \
- file://0001-shell.c-Fix-format-not-a-string-literal-warning.patch \
- "
-
-SOURCES = "attach.o auth.o btree.o btree_rb.o build.o copy.o date.o delete.o \
- expr.o func.o hash.o insert.o main.o opcodes.o os.o pager.o \
- parse.o pragma.o printf.o random.o select.o table.o tokenize.o \
- trigger.o update.o util.o vacuum.o vdbe.o vdbeaux.o where.o"
-
-inherit autotools pkgconfig
-
-do_configure() {
- echo "main.mk is patched, no need to configure"
- # make pkgconfig.bbclass pick this up
- cp ${WORKDIR}/sqlite.pc ${S}
-}
-
-do_compile() {
- oe_runmake -f ${S}/Makefile.linux-gcc \
- TOP="${S}" \
- BCC="${BUILD_CC}" \
- TCC="${CC}" \
- OPTS="-fPIC -D'INTPTR_TYPE=int'" \
- TCL_FLAGS= LIBTCL= \
- READLINE_FLAGS="-DHAVE_READLINE=1 -I${STAGING_INCDIR}" \
- LIBREADLINE="-L. -L${STAGING_LIBDIR} -lreadline -lncurses"
-}
-
-do_install() {
- install -d ${D}${libdir} ${D}${bindir}
- install sqlite ${D}${bindir}
- install -m 0755 libsqlite.so ${D}${libdir}/libsqlite.so.0.8.6
- ln -sf libsqlite.so.0.8.6 ${D}${libdir}/libsqlite.so
- ln -sf libsqlite.so.0.8.6 ${D}${libdir}/libsqlite.so.0
- ln -sf libsqlite.so.0.8.6 ${D}${libdir}/libsqlite.so.0.8
- install -d ${D}${includedir}
- install -m 0644 sqlite.h ${D}${includedir}/sqlite.h
- install -d ${D}${libdir}/pkgconfig
- install -m 0644 ${S}/sqlite.pc ${D}${libdir}/pkgconfig/sqlite.pc
-}
-
-PACKAGES += "${PN}-bin"
-FILES_${PN}-bin = "${bindir}/*"
-FILES_${PN} = "${libdir}/*.so.*"
-
-SRC_URI[md5sum] = "838dbac20b56d2c4292e98848505a05b"
-SRC_URI[sha256sum] = "3f35ebfb67867fb5b583a03e480f900206af637efe7179b32294a6a0cf806f37"
-
-BBCLASSEXTEND = "native"