aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-04-16 09:31:36 +0800
committerArmin Kuster <akuster808@gmail.com>2021-04-17 06:45:44 -0700
commit16103af5b994479e06d30e17dcea7b3310e6ad42 (patch)
tree72bfd9210548947e1a8e8f1e5299e1abab5d6859 /meta-oe/recipes-support
parent98a26903f770aa8698770817bdaf6175367917e1 (diff)
downloadmeta-openembedded-contrib-16103af5b994479e06d30e17dcea7b3310e6ad42.tar.gz
tbb: Fix build with musl
Need to link libucontext on musl Additionally, mips also needs libatomic Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/tbb/tbb_2021.2.0.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/tbb/tbb_2021.2.0.bb b/meta-oe/recipes-support/tbb/tbb_2021.2.0.bb
index d0e2311402..b05a59dc70 100644
--- a/meta-oe/recipes-support/tbb/tbb_2021.2.0.bb
+++ b/meta-oe/recipes-support/tbb/tbb_2021.2.0.bb
@@ -6,6 +6,9 @@ DESCRIPTION = "Parallelism library for C++ - runtime files \
HOMEPAGE = "https://software.intel.com/en-us/tbb"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=86d3f3a95c324c9479bd8986968f4327"
+
+DEPENDS_append_libc-musl = " libucontext"
+
BRANCH = "onetbb_2021"
SRCREV = "2dba2072869a189b9fdab3ffa431d3ea49059a19"
SRC_URI = "git://github.com/oneapi-src/oneTBB.git;protocol=https;branch=${BRANCH} \
@@ -33,3 +36,10 @@ EXTRA_OECMAKE += " \
# ...
# | make[1]: *** [concurrent_queue.o] Error 1
ARM_INSTRUCTION_SET = "arm"
+
+ASNEEDED = ""
+
+LDFLAGS_append_mips = " -latomic"
+LDFLAGS_append_mipsel = " -latomic"
+
+LDFLAGS_append_libc-musl = " -lucontext"