aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-03-02 17:14:06 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-03-04 09:06:07 +0100
commit920b489ab40001617d5add984d29b6e445c6d9c7 (patch)
tree066e2b95056bf5e5a3157173af7d1fa314a08b08 /meta-oe/recipes-support
parentecc783cb2b16227e8d103b4e491d3ae71eab35ba (diff)
downloadmeta-openembedded-contrib-920b489ab40001617d5add984d29b6e445c6d9c7.tar.gz
opencv: blacklist, not compatible with currently used ffmpeg 3
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/opencv/opencv-samples_2.4.bb2
-rw-r--r--meta-oe/recipes-support/opencv/opencv_2.4.bb3
-rw-r--r--meta-oe/recipes-support/opencv/opencv_3.0.bb3
3 files changed, 8 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb b/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb
index 9d862fe910..ecaae4c08f 100644
--- a/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb
+++ b/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb
@@ -37,3 +37,5 @@ do_install() {
FILES_${PN}-dev += "${datadir}/opencv/samples/*.c* ${datadir}/opencv/samples/*.vcp* ${datadir}/opencv/samples/build*"
FILES_${PN} += "${bindir} ${datadir}/opencv"
+
+PNBLACKLIST[opencv-samples] ?= "Depends on blacklisted opencv"
diff --git a/meta-oe/recipes-support/opencv/opencv_2.4.bb b/meta-oe/recipes-support/opencv/opencv_2.4.bb
index a74853ce3a..eb38a5a6a4 100644
--- a/meta-oe/recipes-support/opencv/opencv_2.4.bb
+++ b/meta-oe/recipes-support/opencv/opencv_2.4.bb
@@ -103,3 +103,6 @@ do_install_append() {
rm -rf ${D}/usr/lib
fi
}
+
+# http://errors.yoctoproject.org/Errors/Details/40660/
+PNBLACKLIST[opencv] ?= "Not compatible with currently used ffmpeg 3"
diff --git a/meta-oe/recipes-support/opencv/opencv_3.0.bb b/meta-oe/recipes-support/opencv/opencv_3.0.bb
index 1948a16565..99ca8b3572 100644
--- a/meta-oe/recipes-support/opencv/opencv_3.0.bb
+++ b/meta-oe/recipes-support/opencv/opencv_3.0.bb
@@ -131,3 +131,6 @@ do_install_append() {
install -d ${D}${datadir}/OpenCV/samples/bin/
cp -f bin/*-tutorial-* bin/*-example-* ${D}${datadir}/OpenCV/samples/bin/
}
+
+# http://errors.yoctoproject.org/Errors/Details/40660/
+PNBLACKLIST[opencv] ?= "Not compatible with currently used ffmpeg 3"