aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-10-03 04:28:30 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-10-06 01:07:53 +0200
commitd93c0965190ef0e80cd61eeb69309f6879826452 (patch)
treecc37ec063cd356156da766f3bb546daf45c82aa7 /meta-oe/recipes-support
parent7f0bf7279da8aa613e0d92e28b0e3deff7b19173 (diff)
downloadmeta-openembedded-contrib-d93c0965190ef0e80cd61eeb69309f6879826452.tar.gz
fftw: add virtual/fftw to PROVIDES and EXCLUDE_FROM_WORLD
* now when sysroot conflicts are fatal we really don't want to build multiple fftw providers in the same sysroot ERROR: The recipe fftwl is trying to install files into a shared area when those files already exist. Those files and their manifest location are: /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/qemuarm/usr/include/fftw3.f Matched in manifest-qemuarm-fftw.populate_sysroot manifest-qemuarm-fftwf.populate_sysroot Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/fftw/fftw.inc2
-rw-r--r--meta-oe/recipes-support/fftw/fftwf_3.3.4.bb3
-rw-r--r--meta-oe/recipes-support/fftw/fftwl_3.3.4.bb3
-rw-r--r--meta-oe/recipes-support/imagemagick/imagemagick_6.8.9.bb2
-rw-r--r--meta-oe/recipes-support/nonworking/fftw/benchfft_3.1.bb2
5 files changed, 10 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/fftw/fftw.inc b/meta-oe/recipes-support/fftw/fftw.inc
index 6bd622d9b8..9007e1d828 100644
--- a/meta-oe/recipes-support/fftw/fftw.inc
+++ b/meta-oe/recipes-support/fftw/fftw.inc
@@ -3,6 +3,8 @@ SECTION = "libs"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
+PROVIDES = "virtual/fftw"
+
RPROVIDES_${PN} += "libfftw3"
SRC_URI = "http://www.fftw.org/fftw-${PV}.tar.gz"
diff --git a/meta-oe/recipes-support/fftw/fftwf_3.3.4.bb b/meta-oe/recipes-support/fftw/fftwf_3.3.4.bb
index 59f4a111f6..7a4fbac8c1 100644
--- a/meta-oe/recipes-support/fftw/fftwf_3.3.4.bb
+++ b/meta-oe/recipes-support/fftw/fftwf_3.3.4.bb
@@ -1,5 +1,8 @@
require fftw.inc
+# conflicts with fftw and fftwl
+EXCLUDE_FROM_WORLD = "1"
+
EXTRA_OECONF += "--enable-single \
${@base_contains('TUNE_FEATURES', 'neon', '--enable-neon', '', d)} \
"
diff --git a/meta-oe/recipes-support/fftw/fftwl_3.3.4.bb b/meta-oe/recipes-support/fftw/fftwl_3.3.4.bb
index 8f37346596..432ff1241e 100644
--- a/meta-oe/recipes-support/fftw/fftwl_3.3.4.bb
+++ b/meta-oe/recipes-support/fftw/fftwl_3.3.4.bb
@@ -1,5 +1,8 @@
require fftw.inc
+# conflicts with fftw and fftwf
+EXCLUDE_FROM_WORLD = "1"
+
EXTRA_OECONF += "--enable-long-double"
SRC_URI[md5sum] = "2edab8c06b24feeb3b82bbb3ebf3e7b3"
diff --git a/meta-oe/recipes-support/imagemagick/imagemagick_6.8.9.bb b/meta-oe/recipes-support/imagemagick/imagemagick_6.8.9.bb
index 9b15f62f21..454db64a93 100644
--- a/meta-oe/recipes-support/imagemagick/imagemagick_6.8.9.bb
+++ b/meta-oe/recipes-support/imagemagick/imagemagick_6.8.9.bb
@@ -3,7 +3,7 @@ SECTION = "console/utils"
LICENSE = "ImageMagick"
LIC_FILES_CHKSUM = "file://LICENSE;md5=5d84c6ddd4028aa53d028b4c50f9361e"
# FIXME: There are many more checked libraries. All should be added or explicitly disabled to get consistent results.
-DEPENDS = "lcms bzip2 jpeg libpng librsvg tiff zlib fftw freetype"
+DEPENDS = "lcms bzip2 jpeg libpng librsvg tiff zlib virtual/fftw freetype"
PATCHSET = "8"
SRC_URI = "http://www.imagemagick.org/download/ImageMagick-${PV}-${PATCHSET}.tar.bz2 \
diff --git a/meta-oe/recipes-support/nonworking/fftw/benchfft_3.1.bb b/meta-oe/recipes-support/nonworking/fftw/benchfft_3.1.bb
index 5da4561680..feb3c3c25d 100644
--- a/meta-oe/recipes-support/nonworking/fftw/benchfft_3.1.bb
+++ b/meta-oe/recipes-support/nonworking/fftw/benchfft_3.1.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
LICENSE = "GPLv2"
# single precision fftw is called fftwf
-DEPENDS = "fftwf"
+DEPENDS = "virtual/fftw"
SRC_URI = "http://www.fftw.org/benchfft/benchfft-${PV}.tar.gz"